Nissan Frontier Forum banner

1 - 5 of 5 Posts

·
Registered
Joined
·
54 Posts
Discussion Starter #1 (Edited)
2008 SE CC 124K. 60K on these rotors. Front inboards. Pads are worn (one fried) but nothing on pads that would appear to cause this pattern. Pads are AZ DG1094. AZ rotors. Thinking back may have seen same pattern when I changed pads and rotors in July 2014 when I bought vehicle used. Dismissed it at the time as being prior owner letting pads go to railroad brakes and changing pads but not rotors. Believe prior owner used Nissan parts. Internet search reveals 2 similar cases (Jeep and a Jag) without viable explanation. Have now changed calipers thinking pistons are worn. Anybody seen this before? Thoughts appreciated.
 

Attachments

·
Rogue Admin
2007 LE 4x4 Crew Cab Long Box
Joined
·
13,358 Posts
I had my OE rotors warp within 20k, Nissan replaced them under warranty. I have never gone back to OE rotors. I can't say for sure how your wear happened, but new calipers is a good start, plus a good bleed.
 

·
Registered
Joined
·
844 Posts
My original front rotors and pads wore very similarily, just the insides. I didn't find an issue anywhere, very odd. Replaced with EBC rotors and pads, serviced the calipers, replaced the slide pins. Wear looks normal thus far.
 

·
Registered
Joined
·
5,992 Posts
Not great but not uncommon. Typically happens when the pads wear too much. My Fronty's front rotors looked about that when I replaced at 75K (first time). Our 2004 Ford Explorer's rotors all look like that front and rear, inside and outside surfaces.
 
1 - 5 of 5 Posts
Top