Nissan Frontier Forum banner

1 - 10 of 10 Posts

·
Registered
2010 Nissan Frontier PRO-4X
Joined
·
5 Posts
Discussion Starter #1
Hey folks. I've been hearing this short rattling noise that sounds like two pieces of sheet metal vibrating against each other. It happens on a cold start when I just start accelerating in first gear and goes away after a couple of minutes once the engine is warm. I'm in a 2010 Pro-4x. I've checked all of the skid plates and heat shields and nothing is loose. Any ideas? I've had someone suggest maybe the catalytic converter is starting to go. I posted a short video to Reddit where you can hear it happen twice.

https://www.reddit.com/r/nissanfrontier/comments/itvtb5
Thoughts?
 

·
Registered
2010 Nissan Frontier PRO-4X
Joined
·
5 Posts
Discussion Starter #3
I only hear wind, sorry. Generally, this is a heat shield on top of the exhaust, each one should have two holding straps. I yanked mine off years ago.
Yeah, sorry. It's there, but it's really brief and subtle...or maybe I'm just going crazy. My wife says she doesn't hear it either. I've been trying to get good audio of it for a couple of weeks now. This was the "best" one. LOL. All the suggestions I've gotten so fair point to the heat shields, but none of them seem to be loose when I check them. Thanks!
 

·
Registered
Joined
·
2,448 Posts
Hard to tell from the video It is not that good. Probably a heat shield you over looked. Double check all the heat shields. Also check the ones above the muffler and the one attached to the under side of the bed. Did you check the heat shields on the exhaust manifolds?
 
  • Like
Reactions: 2013Pro4X

·
Registered
2010 Nissan Frontier PRO-4X
Joined
·
5 Posts
Discussion Starter #5
Hard to tell from the video It is not that good. Probably a heat shield you over looked. Double check all the heat shields. Also check the ones above the muffler and the one attached to the under side of the bed. Did you check the heat shields on the exhaust manifolds?
Yeah, but when I checked them, I was just tapping them with a wrench to see if they rattled. I was just out there fiddling with something else and had the engine running and I noticed a small rattle from the heat shield at the Y in the exhaust near the passenger door. I tightened those clamps up, but it still made the noise when I pulled out of the drivway. I think I'm just going to have to put a wrench on all of the connectors to the heat shields and just tighten them up to see if that does it. Thanks!
 

·
Admin
Joined
·
3,278 Posts
I can hear it in your video. For mine, before they went totally, I would get a “fart” occasionally that sounded like that. When the oem clamps go completely, you’ll know it, because you’ll sound like a rattling tin can sitting at stop lights. I like most here, fixed them with radiator hose clamps.
 

·
Registered
Joined
·
2,448 Posts
Yeah, but when I checked them, I was just tapping them with a wrench to see if they rattled. I was just out there fiddling with something else and had the engine running and I noticed a small rattle from the heat shield at the Y in the exhaust near the passenger door. I tightened those clamps up, but it still made the noise when I pulled out of the drivway. I think I'm just going to have to put a wrench on all of the connectors to the heat shields and just tighten them up to see if that does it. Thanks!
Try using a rubber mallet
 

·
Registered
Joined
·
58 Posts
From what I've experienced on my 2014, its either the straps have broke, or the tab that's welded is cracked. Found even a short crack can cause noises. Use a flat tip screwdriver to lift the shield around the welded tab. Think I've got 5 hose clamps on my exhaust so far!! Soon the shields will go in the trash!! Got a rattle noise that sounds bigger than heat shields!!

Sent from my SM-G970U using Tapatalk
 
1 - 10 of 10 Posts
Top