Nissan Frontier Forum banner
1 - 6 of 6 Posts

· Registered
Joined
·
8 Posts
Discussion Starter · #1 · (Edited)
2012 Frontier Pro-4x

Had an issue start about a month ago when climbing i70 to the Eisenhower tunnel in Colorado. For those who are uninitiated this is a very long steep climb on the highway. When pushing the truck to get some acceleration it all of a sudden shuddered at about 4000 RPM and lost a lot of power. I let off on the gas and slowly accelerated which it then had no issue with. It did feel like it was shuddering when it should have been switching gears.

Ever since this happened, if I get on the truck to get up to speed quickly the same issue happens.

My though tis that the transmission fluid needs flushed, but this was done 15k miles ago, so seems unlikely but is my next step since the symptoms point to this.

My truck also has been throwing Clean Mass Airflow Sensor issues on and off recently. Since I am at a higher altitude in Colorado, could there potentially be an issue with my gas mixture?

Looking to just get some ideas thrown around here for me to check out. Never experienced anything like it in a car before.
 

· Registered
Joined
·
8 Posts
Discussion Starter · #6 ·
Took it back out on the highway yesterday and hit the gas hard to get up to speed. Right around 3500 RPM it stops accelerating, like sudden loss of power, but RPM's will still increase. Almost like it is in neutral, which is really leading me to think this is a transmission issue
 
1 - 6 of 6 Posts
Top