Nissan Frontier Forum banner
1 - 3 of 3 Posts

·
Registered
Joined
·
2 Posts
Discussion Starter · #1 ·
Instrument panel goes dark for 3 to 20 seconds then comes back on sometimes ot does this only once while im driving down the road or several times in a row and I have to struggle to pull off the side of the road......during all of this I do not lose head lights and although I lose power the engine is still running. This problem is extremely Intermittent. I then slowly start to accelerate again and I am on my way until or if ot does it again...I jist replaced my Alternator about 2 months ago and I just fixed my Power Steering Fluid leak by changing both the upper and lower hoses. Also w we checked the batteries' output Normal, the alternator was checked also with a voltmeter and it was also normal. One more fact to consider is that I just changed my oil and oil Filter and ran some Sta-Bil Injector Cleaner and Octane Booster through it...We really could use someones help this is our only Vehicle we cant afford another one right now.......Im praying for an Angel to guide me!
FYI - I have a 2005 Nissan Frontier SE V6 4.0L
Thanks to anyone that can be helpful.
 

·
Registered
2019 Nissan Frontier Pro4x AT
Joined
·
225 Posts

·
Registered
Joined
·
2,538 Posts
The fact that it's intermittent is often a symptom of a poor connection (including grounds).

The nut that attaches the positive battery post clamp to the fuse block is a pretty common trouble spot - It loosens or gets corrosion under it.

 
  • Like
Reactions: wrenchturner
1 - 3 of 3 Posts
Top