Nissan Frontier Forum banner

1 - 5 of 5 Posts

·
Registered
Joined
·
5 Posts
Discussion Starter #1 (Edited)
Hi. Has anyone heard of this issue before:

Sounds and feels like transmission is slamming violently and repeatedly trying to shift at 10 mph. Overdrive light comes on.
Had the #4 coilpack replaced the day before and seemed to have solved the issue that it was replaced for.
Is there another OBD type hookup for the transmission (tcm?) or do all codes go to the ECU ?
There's no codes in the OBD2 hookup except for stupid fuel level code which has been a problem for years.

2007 nissan frontier- stock automatic transmission.
2.5 litre 4 cyl engine.

thanks in advance !!! >:D

Additional; Took truck for test drive with local mechanic and the problem wasnt there, OMG.
 

·
Registered
Joined
·
170 Posts
My truck (4.0) had a similar issue and the valve body went out THREE TIMES. They replaced a sensor in my front trans case and the third valve body which fixed it. There were signs of failure before the code lit up, so I'd take it to a dealer to diagnose.
 

·
Registered
Joined
·
5 Posts
Discussion Starter #3
Thanks for the reply, appreciate it !

Roger that on taking to a dealer. My local mechanical guy didn't find anything wrong nor his transmission guy.
They ran code checks. As of today I got it back and drove it 30 miles to work without issue so keeping fingers crossed.
My frontier is only a 2WD.
 

·
Premium Member
Joined
·
337 Posts
Check the radiator too and see what color the coolant is. I'm not sure if the 4 bangers are acceptable to SMOD like the 4.0's but it was a problem from 05-09 when Nissan changed the radiator. If the coolant is pinkish then you have problems.
 

·
Registered
Joined
·
5 Posts
Discussion Starter #5
Thanks malleusdei321. Will do. BTW, got truck back and its running good. There's a somewhat slight unusual shift from 1st to 2nd or 2nd to 3rd (not sure which yet). Will take it in for trans fluid/filter change but will check for pinkish radiator coolant first.
 
1 - 5 of 5 Posts
Top