Nissan Frontier Forum banner
1 - 5 of 5 Posts

·
Registered
Joined
·
3 Posts
Discussion Starter · #1 ·
I have a 01 frontier and my turn signals just started acting up.. when I turn them on they only blink once or twice then stop.. My hazards work perfect so would this be a the actual turn signal stick going bad?
I've read that both run off the same relay so if the hazards work the relay should be fine..
Just want to make sure before I buy a new assembly..
 

·
Registered
Joined
·
6,761 Posts
Check your bulbs one of them is burnt out. The flasher relay works on load. When you use the turn signal you call on 2 bulbs to flash. With only one bulb drawing load, it is not enough to flash the turn signals. When you turn on the hazards, you are calling 4 bulbs to flash. With only 1 out, you still have 3 bulbs pulling enough load.
 

·
Registered
2019 Frontier SV KC 2WD V6 Auto
Joined
·
1,168 Posts
I have a 01 frontier and my turn signals just started acting up.. when I turn them on they only blink once or twice then stop.. My hazards work perfect so would this be a the actual turn signal stick going bad?
I've read that both run off the same relay so if the hazards work the relay should be fine..
Just want to make sure before I buy a new assembly..
Is this happening on both the left and right turn signals? If you put LED lights in your signal bulbs, try putting the original bulbs back in one by one and test it. If not that, then I think you're likely right about it being the switch. When a bulb burns out, I'd expect your turn signal to blink faster continuously (hyperflash) instead of blinking once or twice then stopping. You could put on the hazards and go look at each bulb just to be sure all bulbs are working.

Let us know what was wrong once you fix it.
 

·
Registered
Joined
·
3 Posts
Discussion Starter · #4 ·
Ok I just went out to check the bulbs and the hazards didn't turn on with the car off.. I started it and tapped the hazards on and off a few times and they worked and for the few mins after my turn signals worked..
Also all the bulbs are working so now im thinking its the relay that's on the brink..
 

·
Registered
Joined
·
3 Posts
Discussion Starter · #5 ·
After my hazards took a dump I was convinced it was the relay and it was.. slapped a new one in and everything's perfect again.. thx 👍
 
1 - 5 of 5 Posts
Top