Nissan Frontier Forum banner

1 - 20 of 26 Posts

·
Registered
Joined
·
38 Posts
Discussion Starter · #1 · (Edited)
I've noticed my 2012 Frontier Pro4X has started jerking forward from time to time. I could be travelling at any speed and all of a sudden it feels like someone gave me a nudge from behind. Anyone know what's happing. Is this a fuel issue or drive train.
 

·
Registered
Joined
·
2,864 Posts
How many miles on the truck, what has or hasn’t been serviced yet, loose of performance or mileage?
 

·
Registered
Joined
·
667 Posts
Do you have any lights? have you put a scan and checked for any codes? there is so many possibilities but sounds more like drive do you have more information? but 1st are we talking about an auto or stick? if auto has the rad been checked for MSOD have you done recently done a flush? have you checked fluid level? do you know what gear this starts at first its while cruising then at full stop? is it trans trying to down shift while cruising? and if at at stop also is it while or coming to a stop that would lead me to harsh downshifts when or if ever was fluid serviced? whats your mileage?
 

·
Registered
Joined
·
38 Posts
Discussion Starter · #4 · (Edited)
136,000km. I've had all the fluids replaced about 2 or 3 years ago. Engine oil obviously every 5000km

Don't have any means of checking for codes. No codes showing up on dash. I have an automatic. This happens at cruising speed. Could be any speed. Does not happen when stopped. All fluids replaced 2-3 years ago. Not clear how this may be linked to the rad coolant.
 

·
Premium Member
Joined
·
7,125 Posts
Battery posts/terminals sturdy/clean/clear? Might sound silly, but stranger things have happened when this basic electrical connection point is ignored.
 

·
Super Moderator
Joined
·
11,252 Posts
I do often get a lot of battery residue on the battery but mainly at the caps. I will check this out.
Those felt pads added to the terminal posts help a bit and some of the anti corrosion spray combined with it even does wonders when added at every oil change, terminals are always perfect when checked. Nissan batteries are NOT maintenance free and sweat, off gas, leak acid so I prefer to change to maintenance free after a couple of years if not sooner. Hope your issue is as easy as cleaning the connections.

Clint
 

·
Registered
Joined
·
26 Posts
::laugh::When I saw the title here I thought of my two brother in laws.
 

·
Registered
Joined
·
289 Posts
Also check for vac leaks. A small leak at idle might not be noticed, yet may cause a surge at higher RPMs. Other things that are cheap enough to check would be fuel filter, air intake leaks, dirty injectors... Could even be a coil pack going out.


As for how coolant can relate, Certain years have had an issue with the radiator leaking between the coolant and transmission fluid reservoirs. This can cause a mix of coolant to get into your transmission and do all sorts of damage. This could cause surging from trans slip.
 

·
Registered
Joined
·
6,568 Posts
I would check the ATF level. Proper way- hot engine/tranny, truck idling. if not at level fill. If burnt smelling drain and fill.
If this doesn't solve things check the rear and front diff fluid level. If good drain and look at the drain plug magnet for metal chunks. Change fluid or if you used high dollar Syn fluid and it still looks clean, put it back in.
 

·
Registered
Joined
·
38 Posts
Discussion Starter · #13 · (Edited)
Not sure if this is related but today afte my truck warmed up completely I turned the heat on and only cold air blew out. After accelerating a few time I finally got heat. This may just be a sticking thermostat. I will need to have my dealer check for vacuum leaks and clean the injectors. My truck showed the symptoms again today 3x in about 2 minutes at 120km/hr. it's hard to describe but I feel it in my seat. I wonder if the back break antilocks are malfunctioning. Kinda feels like that.

Don't really use the cruise so I can't say it's related to that.

Checked traini fluid on the weekend and level was ok and looked the normal red

I'll have the diff checked for any metal shavings.
 

·
Registered
Joined
·
38 Posts
Discussion Starter · #14 ·
My coolant level was low. Such that the reservoir was empty. I filled it then drove it around and then let it sit overnight. In the morning it needed a bit more to get it to the full mark. Oddly enough the jerking motion or perhaps loss of power momentarily has stopped. I'm not sure if the coolant level is linked. I drove my truck 450km to the cottage and back this weekend. No issues at all and the coolant level remained normal. No idea where the coolant went since I've never seen a coolant leak on the driveway or any where else. I'm scheduled for service later this week. I will be having the cooling system pressure checked. Are there any sensors in the cooling system that may force the engine to momentarily shut down if no coolant is detected?
 

·
Registered
Joined
·
38 Posts
Discussion Starter · #15 ·
My coolant level was low. Such that the reservoir was empty. I filled it then drove it around and then let it sit overnight. In the morning it needed a bit more to get it to the full mark. Oddly enough the jerking motion or perhaps loss of power momentarily has stopped. I'm not sure if the coolant level is linked. I drove my truck 450km to the cottage and back this weekend. No issues at all and the coolant level remained normal. No idea where the coolant went since I've never seen a coolant leak on the driveway or any where else. I'm scheduled for service later this week. I will be having the cooling system pressure checked. Are there any sensors in the cooling system that may force the engine to momentarily shut down if no coolant is detected?
 

·
Registered
Joined
·
4 Posts
I saw an article somewhere about coolant leaking into the tranny in trucks over 100k causing tranny damage. My guess is transmission coolant lines corroding inside the radiator.
 

·
Premium Member
Joined
·
12,118 Posts
im not saying cruise control is related. i was more curious about computer controlled input of throttle.

good luck!
 

·
Registered
Joined
·
38 Posts
Discussion Starter · #19 ·
I drove my truck 400km today towing a heavy trailer with a snowmobile. No issues. Like I mentioned in a previous post, the jerking or loss of power I was experiencing stopped once I topped up the coolant reservoir. I'm hoping someone can tell me the relationship bewteen the two because my dealer couldn't. If this was a transmission or differential issue it would not have gone from 2 or 3 symptoms a day to zero in the past two weeks. A conundrum I say.
 

·
Registered
Joined
·
1,137 Posts
With the engine cooled off, check your radiator cap for pink milkshake.
 
1 - 20 of 26 Posts
Top