Nissan Frontier Forum banner

1 - 13 of 13 Posts

·
Registered
Joined
·
67 Posts
Discussion Starter #1
My son in law was using my truck going to work, before this pandemic, now he is working at home. The truck set on the driveway never got started. He noticed the tail lights/backlight are ON (red), he can not figure out how to turn them off. He said the switch are off. Battery is dead. I got the battery jumper from my daughter car and truck started. The ABS light is ON while I was driving it to home and the tail light always ON. My suspect is, Looks like my tail lights are shorted or grounded, can not be controlled by switch. I don't think my truck has ABS brake system. Any idea or suggestion?
 

·
Registered
2004 Nissan Frontier XE KC KA24DE
Joined
·
2,349 Posts
Check the rubber stop for the brake light switch.
 

·
Registered
2004 Nissan Frontier XE KC KA24DE
Joined
·
2,349 Posts
Here's a schematic. #46512 is the rubber stop.
I used a body panel clip to replace the rubber stop when mine gave way.
 

·
Registered
2004 Nissan Frontier XE KC KA24DE
Joined
·
2,349 Posts
There's actually 2 rubber stops on the brake pedal bracket where the rubber stops mount for automatic transmissions. One for the shift lock and the other for the brake light.

There will also be one for the clutch pedal if manual transmission.
 

·
Registered
Great truck
Joined
·
851 Posts
So if your cruise control doesn't work, also, that's a sure sign it's one of those rubber deals.

I super glued a penny onto the spot, if I remember right
 

·
Registered
Joined
·
67 Posts
Discussion Starter #7
I found pieces of rubber bumper on the floor mat. tried to put them together, no luck. I guess I have to buy a new one. Maybe I'll follow your tip, use penny right now. Thanks again.
 

·
Registered
Joined
·
67 Posts
Discussion Starter #11
Thanks for your help. My main problem on this project truck is the vibration around 45mph, only on this speed. During the vibration my CEL comes on and keep flashing. I know well, it's the pesky P0302. I'm thinking of replacing the distributor because I've replaced almost everything. Any input?
 

·
Registered
2004 Nissan Frontier XE KC KA24DE
Joined
·
2,349 Posts
Thanks for your help. My main problem on this project truck is the vibration around 45mph, only on this speed. During the vibration my CEL comes on and keep flashing. I know well, it's the pesky P0302. I'm thinking of replacing the distributor because I've replaced almost everything. Any input?
Any vacuum leaks?
 

·
Registered
Joined
·
67 Posts
Discussion Starter #13
I found a leak around the big pipe going to the throttle body. I can not loosen the nut so I put RTV around it. I put back my old TPS, adjusting 3 screws on the throttle body between the firewall and the distributor. One vertical screw has securing nut, I think this is for temperature, one diagonal screw (I think rpm adjust) and one vertical screw further back ( not sure but it moves the roller in and out over the cam (temperature). According to the hood decal, my truck is 20 degrees BTC for distributor. I test drove yesterday and did not feel the vibration. It's very short distance, need to test drive maybe a mile.. I started the truck today and the idle rpm is around 1100 rpm (cold) steady and drop to 900 rpm. I'll post it here for any result.
 
1 - 13 of 13 Posts
Top