Nissan Frontier Forum banner

1 - 20 of 33 Posts

·
Registered
Joined
·
220 Posts
Discussion Starter #1
truck starts, and chugs then dies. Bit of a gas smell. Triple checked everything. I disconnected battery negative for the night, will try again tomorrow. If I killed the maf, would that throw a code I could read with Cortex? Very sad right now :(
 

·
Registered
Joined
·
2,928 Posts
if u killed the maf, u'd more than likely have a code
 

·
Registered
Joined
·
693 Posts
Def throw a code. Man that sucks! Sorry to hear.
 

·
Registered
Joined
·
6,391 Posts
I check the MAF connection is seated all the way, adn the maf sensor is secured to the tube. Then cehck the joint between the intake pipe and the throttle body, make sure the boots are seated an teh clamps are tight. Don't want to get any unmetered air through there.
 

·
Registered
Joined
·
26 Posts
yeah, check for leaks. Did you touch the throttle plate? Possible you could have upset the spring rate or TPS sensor. Also there might be a ground wire that was cut by accident.
 

·
Registered
Joined
·
220 Posts
Discussion Starter #7 (Edited)
yeah, check for leaks. Did you touch the throttle plate? Possible you could have upset the spring rate or TPS sensor. Also there might be a ground wire that was cut by accident.
yes I opened it to check out the mesh! Ugh was that a bad?

Does the volant come with a oiled filter? If so check the MAF and see if there is oil on it.
It's the powercore filter. I read somewhere that the maf doesnt want to be upside down, is that true? It only seemed to want to attach one way.
 

·
Registered
Joined
·
1,410 Posts
yeah it will only go in one way, i remember reading one member had to send his volant back because the mounting surface for the MAF was uneven so the MAF didnt seat well on it and wasn't sealing. How to:ECU Reset,Throttle & Accelerator Position Learning - Nissan Titan Forum go here and do the ecu reset then accelerator pedal release pos learning then the throttle valve closed position learning. then if that works for you after your truck warms up do the idle air volume learning (that one is good to do after an intake to smooth out your idle)
 

·
Registered
Joined
·
220 Posts
Discussion Starter #9
cool, thanks Colin.
 

·
Registered
Joined
·
220 Posts
Discussion Starter #10
fixed

the MAF was upside down...I put it in like that because the holes didnt line up otherwise. Guess it matters. Took pipe off, removed MAF. Had to dremel one of the screw holes. See pic. Put it back together, vroom vroom working. Went for drive....initially very disappointed, felt slower, although the sound could best be described as a deviant, ungodly wailing. Kept going to see if computer would sort itself out. Well it did after about 20 miles. The tone mellowed out, and it kept pulling harder. I came up to a red light, and a brand new Acura TL pulled beside me in the f*ck-you lane. I thought oh my, what did I do to derserve this? I inch forward quickly and the driver, a 70+yr old guy with an Acura hat gives me a long hard look. Kay it's on, I switch to 4WD (roads are wet) as I suspect he is in a SH-AWD. Light goes green and I quickly grab a length. He is at my back bumper and gritting his dentures. He loses a few more feet before he stays with me, and then starts pulling closer, alas his lane was about to end and he pulled in behind me....I'd say we were around 70 mph when he shut it down. Motor Trend lists his car at [email protected] and 0-60 in 6.5, so I'm happy with the win ( yes he woulda passed me if it went further).
 

Attachments

·
Registered
Joined
·
220 Posts
Discussion Starter #12
LOL, go smoke some weed Squamish. :)
 

·
Registered
Joined
·
1,410 Posts
glad it all worked out for ya easy enough. now that you've mentioned it i think i've seen a couple other people say they had the screws not lining up prob too
 

·
Registered
Joined
·
234 Posts
Yup volant's Q&A sucks balls, someone there needs to get :whip: seriously hard!!


I have a 30 watt soldering iron with an exacto knive type attachment I used to move the hole.
 

·
Premium Member
Joined
·
262 Posts
So Relic .. overall you happy with the sound and performance?.. where does it give the extra ummmph ... mid or bottom end? .. cause my truck seems to loose torque/hp midrange on the 87 tune - does the volant help with that? ( Yea I know .. I should be running 91 .. )

d-mo
 

·
Registered
Joined
·
220 Posts
Discussion Starter #17
So Relic .. overall you happy with the sound and performance?.. where does it give the extra ummmph ... mid or bottom end? .. cause my truck seems to loose torque/hp midrange on the 87 tune - does the volant help with that? ( Yea I know .. I should be running 91 .. )

d-mo
funny you ask, I've been using the 87 tune myself last week or so after getting used to the 93+3 degrees. It still has more power everywhere, just slightly muted on 87 tune. I'll be switching back to 93 today...you get 4x the bonus points on Sunoco Ultra gas, and my mileage is the same so win win win.
I would buy a Volant again.
 

·
Registered
Joined
·
2,132 Posts
Glad things worked out.

the MAF was upside down...
^So, which way is the "silver" side facing now, up or down?
 

·
Registered
Joined
·
220 Posts
Discussion Starter #19
the way that works better? I dont remember, I think it was silver down.
 

·
Registered
Joined
·
274 Posts
I think it's silver up. That's the way mine was
 
1 - 20 of 33 Posts
Top