Nissan Frontier Forum banner

1 - 7 of 7 Posts

·
Registered
Joined
·
179 Posts
Discussion Starter #1
So after I spent 9 hours today pre-soldering up my harness with steering wheel interface, micro parking brake bypass and running reverse wires from under the hood, backup camera to the tailgate, power and signal and remote turn on to the back for the Bazooka tube, Bluetooth microphone up to the upper console, etc. it was finally time for the big payoff, installing the Alpine head unit.....

Then, BOOM!!! Harness Interruptus,,



I have a 2010 PRO4X, six disc non Rockford head unit... Everything I could find said I needed a Metra 70-7552 (actually a AutoHarnessHouse.com AHH-70-7552). But as you can see, that does not work. The plug in my hand is the 70-7552 and the two plugs at top are what went into the radio..

Can anyone help?

I put the dash back together to get to work tomorrow and forgot to plug in the antenna, and I swapped my aux connector for a marine unit I found with USB and Aux so I am gonna be ridin' silent.. lol.

Here's the back of the radio, and the front.





Sent from my iPad using Tapatalk Pro
 

·
Registered
Joined
·
179 Posts
Discussion Starter #3
No amp under the seats, just the Bluetooth module. It looks like I need Metra 70-7550 but I don't know where the steering wheel wires will be now with that harness. All of the instructions with the ASWC-1 expect a single 16 pin connector


Sent from my iPad using Tapatalk Pro
 

·
Premium Member
Joined
·
1,913 Posts
Have you read through rlowery's thread?
The 2nd row, 2nd connector looks to be your 20pin (you can verify by looking at the FSM wiring diagram and verifying that connector has power, illumination, speaker outs, ...) that is what your Metra harness should plug to. As for the SWC, you're better off getting the harness from ae64 as he incorporates the spliced-in wires to his harness.
 

·
Registered
Joined
·
179 Posts
Discussion Starter #5

·
Registered
Joined
·
13 Posts
Following! Im in the process of doing the exact same thing. I have the exact same 6 disc HU as you have. Im installing a Pioneer AVH-200EX with backup camera. I bought the Metra 70-7550 harness and the ASWC-1. I havent gotten the ASWC in yet and now after reading your thread, it seems as though thats not what Im needing. GRRRRR Ive never in my life had this much trouble installing an aftermarket in a vehicle. Im by no means a professional, but i've done a few installs. Keep us updated, anxious to see how this is gonna play out.
 

·
Premium Member
Joined
·
5,877 Posts
Metra 70-7550 is for the head unit only; to get the steering wheel controls working you need to add 3 wires to the Metra 70-7550 or splice into the factory side harness, should be similar to this:

PIN 6: Violet/Silver Dot <------> ASWC-1 Gray/Blue
PIN 15: Tan/2 Silver Dots <------> GROUND
PIN 16:Lt. Grn/2 Silver Dots <------> ASWC-1 Gray/Red

Since you have a 2010 the wire colors might be different but the pin positions are the same, these are the same extra 3 wires that you get with the AE64.com harness.
 
1 - 7 of 7 Posts
Top