Nissan Frontier Forum banner

1 - 8 of 8 Posts

·
Registered
Joined
·
25 Posts
Discussion Starter · #1 ·
Ok, I put in my new CAI but I forgot to connect the air temp sensor. As soon as I turned on the frontier the light came on dangit. I connected the sensor but now how do i turn off the service engine soon light????

I already tried diconnecting the battery for like 10 min and that did not work. Anyone else knows how to do this or reset the computer. Its a 2003 frontier.

Thanks guys.
 

·
SHIFT_Otaku(Assist - Adm)
Joined
·
1,482 Posts
disconnect you negitive cable from your battery for an hour (most cars is 30~ mins or so).

this is a good idea anytime you do a mod involving intake.
 

·
Registered
Joined
·
2,963 Posts
If that doesn't work go to an auto parts store like Auto Zone they will pull & clear your codes for free,at least they do down here.
 

·
Registered
Joined
·
36 Posts
It should turn off after you drive it around for a few days. I put my gas cap on wrong and light came on. Put cap on right and 48 miles later it went off.
 

·
SHIFT_Otaku(Assist - Adm)
Joined
·
1,482 Posts
marin265 said:
It should turn off after you drive it around for a few days. I put my gas cap on wrong and light came on. Put cap on right and 48 miles later it went off.
I dont think so...

A gascap error is one that the computer is set to recheck and clear if found to be fine...
a temp sensor failure, or maf failure even if it is found to be in working condition will require the computer to be reset to clear the code... as if a slight failure of these parts can cause catastrophic failures.
 

·
Registered
Joined
·
25 Posts
Discussion Starter · #7 ·
everything is good :) i reset the computer how tc3driver said and it worked. But to make sure i took of the negative terminal for like 4 hours if not more. :D
 

·
SHIFT_Otaku(Assist - Adm)
Joined
·
1,482 Posts
Glad to be of service XD
 
1 - 8 of 8 Posts
Top