Nissan Frontier Forum banner
1 - 20 of 31 Posts

· Registered
2004 xe crew cab
Joined
·
80 Posts
Discussion Starter · #1 ·
Hey guys so I was very excited recently because I have 399,985 miles and can’t wait to see it hit the 4 but it got halted truck won’t crank at all and now I got a camshaft position sensor code so I swapped distributor still nothing I swap timing belt still nothin I check all fuses nothing I check the camshaft sensor plug I got power and ground and reference all work I check small 2 wire plug that both run to ignition module and cam sensor both have power I checked the ecu relay still won’t work I looked through main harness can’t see any bad wires battery is good I’m running out of things to test I’m praying to the Nissan gods it’s not the ecm
 

· Registered
2004 xe crew cab
Joined
·
80 Posts
Discussion Starter · #3 ·
It doesn't sound like a sensor issue. Have you checked the battery connection and vehicle grounds?
I just got new terminals installed and filed and cleaned up the ground located on the intake manifold everything else seems to be powered good do you by chance know exactly where it grounds
 

· Registered
2004 xe crew cab
Joined
·
80 Posts
Discussion Starter · #6 ·
Im gonna double check all the grounds I cleaned as many as I could I just wish I could find the exact ground I looked at a few diagrams that’s what led me to look at ecu sensor but I know the camshaft code can block the stater signal as a fail safe
 

· Registered
2004 xe crew cab
Joined
·
80 Posts
Discussion Starter · #8 ·
When was the starter changed last?
I did the stater about
When was the starter changed last?
It was about 23,000 miles ago and a couple years it’s not too old but I got a pretty crazy oil leak on passenger side I cleaned the stater very good from oil should I get it tested possible when I turn the key all the lights come and I turn it to start and the go very slightly dim like normal when it cranks it just won’t crank
 

· Registered
Joined
·
3,598 Posts
The starter solenoid connects to the battery cable, plus a smaller light gauge wire. If you can hotwire a 12v jumper from the battery to that smaller wire, the starter will activate if it's any good.
Jump from the positive battery post. Or from the cable at the solenoid if you can reach it.
 

· Registered
Joined
·
4,185 Posts
Yes, concentrate on the failure to crank condition FIRST.

The starter solenoid connects to the battery cable, plus a smaller light gauge wire. If you can hotwire a 12v jumper from the battery to that smaller wire, the starter will activate if it's any good.
Jump from the positive battery post. Or from the cable at the solenoid if you can reach it.
I'd put in neutral, and momentarily jump from the large positive terminal on the starter solenoid to the smaller terminal on the starter solenoid. If that doesn't spin the engine, tap on the starter a couple of times with a hammer and try again.

Jump start try from a different vehicle is also a good idea, assuming all electrical connections are good and clean.

Since the lights dim when you try to start, shows that the electrical part of the ignition switch is working.
 

· Registered
2004 xe crew cab
Joined
·
80 Posts
Discussion Starter · #11 ·
yeah I guess I possibly got a little overzealous with the code and didn’t focus on the no crank first I just assumed the signal was blocked from the code I’ll try the jumper and if still nothing I’ll take to autozone for the warranty
 

· Registered
2004 xe crew cab
Joined
·
80 Posts
Discussion Starter · #13 ·
The purpose of jumping it is to test the starter without removing it.
If the starter jumps, it's good, and the problem is further back in the circuit.
I didn’t get to try and test it last night I will today after work I still had all the stuff yanked out from the timing belt job
 

· Premium Member
Joined
·
3,928 Posts
Update stater spun motor did not so I assume the plunger is probably seized?
Possibly, or the teeth on the flywheel/flexplate are chewed off OR if it has a flexplate, it may have broken around where it bolts to the end of the crank. Bad starter is most likely, but you may want to take a look at the teeth and also try and move the engine using a prybar or large screwdriver on the flywheel/flexplate.
 

· Registered
2004 xe crew cab
Joined
·
80 Posts
Discussion Starter · #16 ·
Possibly, or the teeth on the flywheel/flexplate are chewed off OR if it has a flexplate, it may have broken around where it bolts to the end of the crank. Bad starter is most likely, but you may want to take a look at the teeth and also try and move the engine using a prybar or large screwdriver on the flywheel/flexplate.
Flywheel good
Starter good
Motor cranked
Serpentine belt adjuster bolt break danced
 

Attachments

· Registered
Joined
·
3,598 Posts
Update stater spun motor did not so I assume the plunger is probably seized?
Going forward, if you cross the two large terminals on the solenoid, you are actually bypassing the solenoid, and it will spin the starter without cranking the engine.
If you apply 12v to the small wire instead, it will spin the starter and also push the starter gear into the flywheel/flexplate to get it cranking.
 

· Registered
2004 xe crew cab
Joined
·
80 Posts
Discussion Starter · #18 ·
Going forward, if you cross the two large terminals on the solenoid, you are actually bypassing the solenoid, and it will spin the starter without cranking the engine.
If you apply 12v to the small wire instead, it will spin the starter and also push the starter gear into the flywheel/flexplate to get it cranking.
I ran a jumper from the battery to the starter while my wife looked at the crankshaft I didn’t know just crossing the terminals can do that
 

· Registered
2004 xe crew cab
Joined
·
80 Posts
Discussion Starter · #20 ·
You gotta be careful when jumping the starter. If the key is on, the engine will start. If it's a manual transmission, it will start in gear. Also, an automatic transmission will start in gear.
Yeah that could be problematic lol also by chance anyone know where I can get that bolt I tried Napa and a couple hardware stores all said no dealer has a kit that has it for like 130
 
1 - 20 of 31 Posts
Top