Nissan Frontier Forum banner
1 - 12 of 12 Posts

·
Registered
Joined
·
142 Posts
Discussion Starter · #1 · (Edited)
Say I rev to 3000 rpm in 1st gear, then clutch it to shift to 2nd... The rpm stays at 3000 for about a half second before dropping back down. It makes it hard to smoothly accelerate. I was thinking maybe some kind of Idle Air Control Valve, but when it idles, it idles below 1000 rpm, just like it should. It passed smog with almost no emissions, and there is no check engine light. Just wondering if anyone had ideas what might be causing this.
BTW the truck is a 2003 with the 4 banger and stick shift.
 

·
Registered
Joined
·
142 Posts
Discussion Starter · #3 ·
When I lift my foot off the gas, the pedal comes up freely, and I can't find it binding or sticking anywhere. I might try to post a video to youtube of the tach doing it, and put a link to show what it's doing....
 

·
Registered
Joined
·
192 Posts
I hate it. There have been threads on here and it was concluded that it was emissions related. The moment you lift your foot off the pedal, the revs "hang" for a bit to burn off the unburnt fuel before dropping down rpm.

Another theory was the very heavy flywheel the ka24de in our truck has.

It could also be a combination of these two things.

This is one of my ONLY gripes with the truck too. I hate the rev hang with a passion, especially after driving an older car that drops rev immediately after the pedal is released.
 

·
Registered
Joined
·
3,063 Posts
ive heard ppl say its from the heavier flywheel?
 

·
Registered
Joined
·
192 Posts
Has anyone tried using a lightened flywheel from a 240sx? The only problem I could see is losing the rotating mass (thus high inertia) of the flywheel when hauling heavy loads.
 

·
Registered
Joined
·
142 Posts
Discussion Starter · #7 ·
It's not flywheel because even if I leave it in gear and slow down to drop the rpm below 1000 it creeps back up to about 2000 before dropping to 1500 then back to about 1000. Do these trucks have an idle air control valve or something? If I put it in 1st gear, no gas, and let the clutch out, it just stays about 1500 rpm and goes. It's really annoying. I've never had anything do this before unless there was a vacuum leak or something...
 

·
Registered
Joined
·
3,063 Posts
sounds dumb but check your airbox and maf for objects to see if its secured
 

·
Registered
Joined
·
142 Posts
Discussion Starter · #9 ·
Yeah, my plan for today is to clean the MAF and try to clean out the IAC valve. The Hayne's manual says to test it for resistance between the terminals, so I may as well try that as well. Anyone cleaned the IAC?? Anything in particular I should know before doing it?
 

·
Registered
Joined
·
20 Posts
I know this may be a shot in the dark but did you ever figure out the issue? I'm experiencing a similar thing in my 2001 XE.
 

·
Registered
Joined
·
3,464 Posts
I've got 1998 and 2004 frontiers with 4-cylinder engines and 5-speeds (14 and 7 years with me respectively, 237K and 103K miles). Neither has this issue.
 

·
Registered
Joined
·
445 Posts
Had a similar issue on two different cars with two different solutions. On my s13 it was the throttle cable adjustment was too tight. On my s12, it was IACV.
 
1 - 12 of 12 Posts
Top