Nissan Frontier Forum banner

1 - 9 of 9 Posts

·
Registered
Joined
·
20 Posts
Discussion Starter · #1 ·
Hey guys I have a 2005 frontier nismo with 180k miles. A couple of weeks ago the rear diff was working fine. Got in a spot that I needed it, hit the button. It flashed three times and went away. After that it wont even flash until I turn the truck off and back on and it still only blinks three times. Any advice? Thanks!

-JP
 

·
Registered
Joined
·
972 Posts
Have you done any other diagnostics? Have you checked the wiring and fuses? How fresh is your differential fluid? Has it ever had water in the diff?

I hit a branch the other day and ripped off the ground strap on my catalytic converter. It's possible you broke a wire.
 

·
Premium Member
Joined
·
12,118 Posts
i would check your wiring. ive seen this on a few different models so far. split is likely at the plug on the differential.
 

·
Registered
Joined
·
20 Posts
Discussion Starter · #4 ·
Yea its got to be wiring I just wasn't sure if someone else had a similar problem. I will check under it tomorrow and get back with yall about what I see
 

·
Registered
Joined
·
20 Posts
Discussion Starter · #5 ·
Didn't see anything that looked to be out of place. But interesting enough I did just have the cats replaced since the last time I used it.. Where is that ground connected to?
 

·
Registered
Joined
·
20 Posts
Discussion Starter · #6 ·
Took a closer look, it was a snapped wire right on the connector. Blue in color I do believe. Will be replacing next week!
 

·
Registered
Joined
·
20 Posts
Discussion Starter · #7 ·
So after a little more digging, I found that my rear diff lock is aftermarket and I did not install it. Ive been able to lock the diff in 2wd, 4wd high and low. I thought this was standard until I had this issue and need a new connector. The wire split so close to the connector on the diff I cant splice it. Looks like I need a new connector but the problem is I am not sure what aftermarket company it came from. Does anyone have any ideas? I can see the stock connector right about the one mine is hooked up too. I can add pictures later if anyone would like. Thanks in advance
 

·
Premium Member
Joined
·
3,880 Posts
Someone probably did the anytime e locker mod. The connection and the diff is the same as factory with all the wiring changes made behind the dash.

If you know how to de-pin a connector you may be able to salvage the one you have. If not I'd look around at some junkyards.
 
1 - 9 of 9 Posts
Top