Nissan Frontier Forum banner
1 - 7 of 7 Posts

·
Registered
Joined
·
637 Posts
Discussion Starter · #1 ·
It seems most noticable when I get off the freeway and driving surface streets to my house.

As the RPM's increase and get just above the 2k rpm mark it makes a slight rattle or clatter. It will shift into the next gear and as the rpms increase to about the same mark it does it again. Again, 2,000 to 2,200 rpm's seem to be the magic range.

Sometimes it sounds like a heat shield and other times like valves. Its weird and doesnt really sound normal. Anyone else notice this? Any ideas?
 

·
Registered
Joined
·
832 Posts
catalytic converter, probably a failed PRe-cat... give your catalytic converters a good hit with something and see which one is rattling...

Mine's doing EXACTLY as you describe after i had a p0420 code for about a thousand miles.


But in your case, do check your heat shields. The heat shields on the headers of my rodeo were notorious for coming a little bit loose... tighten of the bolts silenced er'.
 

·
Registered
Joined
·
492 Posts
Back when I got my truck in 05 they had some issue with the Intake Manifold Collector on the first models. Between 2k-2200k you can here the rattle of the two butterfly flaps in the Collector. Mine was replaced and all was good. There is a TSB on this issue but it was for the earlier models only. They have a way of testing the Collector to see if has a problem. Hope this helps some.
 

·
Registered
Joined
·
637 Posts
Discussion Starter · #6 ·
Back when I got my truck in 05 they had some issue with the Intake Manifold Collector on the first models. Between 2k-2200k you can here the rattle of the two butterfly flaps in the Collector. Mine was replaced and all was good. There is a TSB on this issue but it was for the earlier models only. They have a way of testing the Collector to see if has a problem. Hope this helps some.
Yea, I read about this issue on the Xterra Forum and it too was an 05' Mine is very faint and you really have to listen to hear it. Was yours pretty loud?
 

·
Registered
Joined
·
358 Posts
looks like i know what I'm doing soon. my '05 just had one cat replaced under warranty (warranty is 80k miles on emmisions parts) after throwing a 0430 code.
I have the weird faint rattle at 2k-2200 rpm. only when accelerating. with no load engine revs clean and smooth. used synthetic oil for a couple yrs, but switched to a blend last year. use lucas gas treatment every 5-6 tanks for good measure. thought it was valves and regular gas, until i found this thread. at least i feel more confident that i am not looking at major engine work at 84k miles.... my last KC had 190k on it, and i sold it still running....
 
1 - 7 of 7 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top