Nissan Frontier Forum banner

1 - 15 of 15 Posts

·
Registered
Joined
·
115 Posts
Discussion Starter #1
What are you guys using to lube your radflos and uca. I've tried several things but it comes right back in a day or two. Had them on for around 2 years, does it get to a point that they need to be pulled out and cleaned and regreased with some sort of commercial grade lube? Any help is good help cause I'm about ready to sell to save my sanity
 

·
Registered
Joined
·
377 Posts
Can you pin-point where the noise is coming from? When I had a squeaking problem with mine, it turned out that I had a prematurely worn heim joint on a UCA. Called Greg and he sent me some new, improved ones. If you're going to lube, dry lube such as graphite seems to be the way to go because you'll otherwise attract a lot of crap to the joints. From what I've read on here though, lubing seems to be a short term fix. See if you can find out if something is worn out.
 

·
Registered
Joined
·
115 Posts
Discussion Starter #3 (Edited)
I get all kinds of squeeks from what seems like everywhere but when I lube with something like a silicon lubricant I will spray the heim joints where the uca's connect and the top of the coilover. After that it is completely silent for a couple days and then slowly gets worse again. About day 5 it is worse than if I would have lubed nothing..even if I'm sitting still and just turn the wheel slightly it will squeek, but then slowly gets a little better, I assume because the lube has worn off.
Anyone and everyone...HELP PLEASE!!
 

·
Registered
Joined
·
115 Posts
Discussion Starter #5
but lube with what?...I obviously am touching on the right spots but the noise just creeps back
 

·
Registered
Joined
·
115 Posts
Discussion Starter #7
Figured I'd update this with my expensive resolution to the problem since nothing suggested worked... buy new uca's... not real feasible, but hit a culvert with full coverage and presto.
 

·
Registered
Joined
·
3,063 Posts
Figured I'd update this with my expensive resolution to the problem since nothing suggested worked... buy new uca's... not real feasible, but hit a culvert with full coverage and presto.
but in time the sqeaks will come back. why didnt you grease them instead of using silicone spray lube why didnt you try replacing bushings? buying new was kinda overkill dude lol
 

·
Rogue Admin
2007 LE 4x4 Crew Cab Long Box
Joined
·
13,738 Posts
I have tried a few different products, and so far the best seems to be Gunk Dry Graphite lubricant. I think it must have Moly in it, as it comes out black - but I like that as it is easier to see where you have sprayed it. The lube is not broken down by water or 700f heat. Expensive, but so far, so good
 

·
Registered
Joined
·
115 Posts
Discussion Starter #10
Good to know zed...what is moly?
 

·
Registered
Joined
·
52 Posts
Buy a Raptor and take it to the dealer when it squeaks!

MY UCAs has been squeaking for over a year and still squeak after replacing all the heim joints. Oh and there is a clunking sound so the uniballs are worn out and I don't even wheel!

The Raptor is looking better all the time! lol
 

·
Registered
Joined
·
2,587 Posts
I have not had any problems with mine ever since I stopped using WD-40 on them
 

·
Registered
Joined
·
115 Posts
Discussion Starter #14
What is a raptor JKL?? Is there a joke there somewhere?
And to update, the new ones have started squeaking as well but with the tranny on its last leg, the fuel sender being shot, and various other tidbits with this worthless heap of metal.... another culvert and with good timing, a couple trees for good measure, I will finally be rid of this nightmare. I loved this truck for what it should have been but alas it is not.

If I can find the time beforehand, I will try to pull off any mods I can get away with
 
1 - 15 of 15 Posts
Top