Nissan Frontier Forum banner

1 - 1 of 1 Posts

·
Registered
Joined
·
36 Posts
Discussion Starter #1
2002 Nissan
Frontier XE 2.4L 280k miles. Just replaced EGR valve and all the hoses because of a check engine light. Not even 2 blocks down the street after getting this fixed, the CEL comes on again. Went to Oreilys, ran the scan tool on it and it came back P0420 Bank 1. Bought the pre-cat and went ahead and purchased the catalytic converter as well. I went ahead and started to unbolt the catalytic converter and one of the bolts broke off. Then turns out the pre-cat came in but the regular cat won't be in until Thursday. Spent the entire afternoon taking off the old pre-cat and installed the new one. Turned the truck on and immediately it sounds awful because of the vacuum leak from the old catalytic converter from the broken bolt. Then I notice smoke from under the engine so I walk around and theres a thin burning smoke coming from the top of the pre-cat so I turned the engine off and let it sit overnight. Come out early this morning and as soon as I cranked the truck up cold I crawled underneath and put my hand on the exhaust right after where the precat connects to the long tube and the truck hasn't even been on 10 seconds and it starts getting really hot right away and again I get up and look under the engine bay and theres a small amount of smoke coming from the top of the pre-cat again like its burning.

I'm stumped, the job wasn't hard at all it was mostly a pain in the *** getting the 5 bolts off and the having to take off catalytic converter so that the precat would come off but other than that I'm positive that I installed this correctly. Any ideas why it would be doing this? I'm getting the new cat in tomorrow and will be installing it.

As a side note, the check engine light is off now and isn't throwing any codes but i'm afraid to drive it because of this smoke from the pre-cat. Any ideas please!​
 
1 - 1 of 1 Posts
Top