Nissan Frontier Forum banner

1 - 9 of 9 Posts

·
Premium Member
Joined
·
6,429 Posts
Discussion Starter #1
has anyone one had go out on there truck ? mine is making noise like its out of fluid but the resevoir is full
also the fluid was flushed about 3k ago when i put a new steering box in
 

·
Registered
Joined
·
12,584 Posts
mine has been making noise for years. every time i wheel hard (lots of time spent with the front diff locked) or do some "go fast" stuff it gets a little louder. might be the fluid heating up and loosing viscosity. i don't know. i have been on the same pump/box since i got the truck and it has always been fine. whenever it makes noise, it usually stops after a few more drives. maybe air in the system from extreme angles?
i flushed it probably close to two years ago.
 

·
Premium Member
Joined
·
1,690 Posts
My pump make all kinds of noise in the mornings when it is cold after the truck heats up it goes away. I have no leaks and plenty of ps fluid. I figure that it is just the nature of the beast and I do not have any plans anytime soon to change it out until it takes a dump
 

·
Premium Member
Joined
·
6,081 Posts
Put In Lucas Power Steering Conditioner And Stop Leak. Its Worked Great For Me Everytime Ive Used Or Recommended It
 
  • Like
Reactions: shakedownstreet

·
Registered
Joined
·
1,208 Posts
There is a screen inside the res of the pump. I cleaned it out 1 qt of new fluid and i been good ever since
 

·
Registered
Joined
·
53 Posts
Mine for the longest time would have a no p/s turning right, and have p/s turning left. But, after the big freeze that we had here, everything seems to be working fine, accept for the noise. So as long as it's working now, I'm not going to mess with it. Accept for fixing the hose that is completely soaked by p/s fluid.
 

·
Registered
Joined
·
9 Posts
04 xe cc
when cold i have no ps on right side only, but after a few turns or a couple of min. its fine. seems like it might be pressure (only on right), but i dont know.
 

·
Premium Member
Joined
·
6,429 Posts
Discussion Starter #8
yesterday i dumped all the fluid out and blew the rest out with C02
found the screen was torn , so maybe something sneaked into the system , put new tranny fluid and the noise is gone
ill end up buying a new resevoir or screen
 

·
Registered
Joined
·
132 Posts
Put In Lucas Power Steering Conditioner And Stop Leak. Its Worked Great For Me Everytime Ive Used Or Recommended It
I was having the same issues, and thats exactly what I did, and it went away for now.


yesterday i dumped all the fluid out and blew the rest out with C02
found the screen was torn , so maybe something sneaked into the system , put new tranny fluid and the noise is gone
ill end up buying a new resevoir or screen
Good Tip, I wasn't sure what I was going to try next if it comes back, now i know.
 
1 - 9 of 9 Posts
Top