Nissan Frontier Forum banner
1 - 7 of 7 Posts

·
Registered
Joined
·
534 Posts
Discussion Starter · #1 · (Edited)
Here's the issue, when unlocking via the remote or switch on the door the locks just click but don't move. It just started today and affects all doors, any idea's are appreciated.

What I've done so far,

1. The drivers door will unlock and lock via the remote but the switches inside only cause a small click to occur.
2. I removed the door panel and disconnected the switch and used the remote to cycle the lock and only the drivers door responds properly, the others just make a click noise.
3. I looked down inside the door with a light and found no evidence of water.

P.S. I found a strange situation... if I press the unlock or lock on the door more than a few times the windows stop working and the switch makes an awful buzzing noise until I take the key out.

Do the windows and door locks function through the BCM? I'm leaning to the possibility that it's going out. Another strange issue that popped up is the passenger heated seat if switched on with blow the fuse, even with all the wires to the seat unplugged.... still not quite sure what to make of this... Heated seats a BCM thing also?
 

·
Premium Member
Joined
·
569 Posts
You puling any codes?

Sounds like BCM but could possibly be masking underlying issue(s).
 

·
Registered
Joined
·
534 Posts
Discussion Starter · #3 ·
I used my Bully Dog to check and no codes, but from what I understand that doesn't mean there isn't something a professional reader could show. Going to call Nissan tomorrow and set up an appointment and prepare myself for the bill.
 

·
Registered
Joined
·
534 Posts
Discussion Starter · #4 ·
Figured it out.

Took out the glove box and poked around the fuse panel... ran my finger down the steel support under the fuse box and boom! cut my finger apart on a sharp 2/10in of steel, i'd liken it to a razor blade tip that wasn't shaved down. This had rubbed against the wiring harness that runs behind the support, worked it's way into some wires in there and shorted. Very happy I found this as Nissan would be charging me a small fortune no doubt.
 

·
Premium Member
Joined
·
256 Posts
Glad to see you found it... I was going to suggest that maybe you had "critter activity" that might have damaged a harness somewhere. Have had a couple instances where seemingly unrelated electrical problems were caused by an animal with an affinity for copper...
 

·
Premium Member
Joined
·
569 Posts
Crazy find and also glad you found it too - no doubt the stealership would have had you out about 5 or 6 bills for a "new" BCM.

If it makes you feel any better, I ran over about 10 feet of broken glass on the road this past weekend. Not too bad but keep finding a small piece here and there between the tread.

:(
 

·
Super Moderator
Joined
·
11,721 Posts
Great news, nothing more satisfying than fixing it yourself.

Clint
 
1 - 7 of 7 Posts
Top