Nissan Frontier Forum banner

21 - 24 of 24 Posts

·
Registered
Joined
·
5 Posts
Bump! Hey, Archer22 - did you ever figure out what was causing your noise? Was it the fuse-box cover inside the lower glove box? Something else?

I have a brand-new ‘19 and have a rattle under similar circumstances as you and can’t isolate. Already tweaked my skid plate, checked/tightened every front suspension and steering bolt, retorqued sway-bar bushing clamps, removed end-linksand yes, tightened antenna. No joy....
Hello I have a 2015 with same noise Your describing. I have done all the tweaks and no luck. Did you ever get yours resolved?
 

·
Registered
Joined
·
174 Posts
Yup - found it, but I had to do it myself. Despite something over 12 times over 3 months it was at the stealership, they only succeeded in grossly overtorquing two body-mounts and causing a leak in the rear driveshaft front seal.

I started putting in an hour or two per weekend looking, using chassis ears, which the stealership called a waste of time and eventually got it: It was the antenna cable where it goes from the inner-fender area to the cowl area. Either there should be a clip or it was missing, but that hard cable was smacking against the sheetmetal. Sounded exactly like a suspension rattle. Since fixed (I zip-tied it securely) it seems so much more solid.

Here’s the interesting part: I had a case open with Nissan, had it escalated and was being a major PITA. Emailed everything and said how much of my time, both back and forth to the stealership and working on it myself, was spent. Plus stress, communication, etc.
I said I wanted some form of compensation and they ended up sending me a check for 4 payments. And I got a good rate and so put zero down, so it was fairly significant.
 

·
Registered
Joined
·
15 Posts
I have a 2012 4x4 with same issue as you guys. Only happens over speed bumps and hard cornering. The sound is more tinny than clunking.
I will look into the antenna issue and let you know.
 

·
Registered
Joined
·
174 Posts
For what it’s worth, mine made noise mostly when going over a slightly rough road surface at slower speeds (sound lost in roadnoise above that) where it was rattling around - didn’t do much over big bumps, at least not that I heard.

Some of the usual suspects you might try if it’s more tinny sounding are the hood bump-stops (adjust them out), the latch (grease the fashissle out of it) and the ‘skidplate’ (it really isn’t - anyway, make sure no edges are near anything else and bend/tweak it away if it is).

Also, if you’re going to the trouble of putting on jackstands, pulling the wheel, the inner fender and the washer bottle (all that stuff needs to come out to get to the antenna cable), you should also put some insulation pieces around the washer bottle when you put it back. I’m not sure, but it may be able to move a bit and either rattle against the inside of the fender or move the fender relative to other parts (it’s heavy when full).

Be glad it’s Summer, btw - I did this in Winter and dumped washer fluid on my pants and shoes - it’s tough to get that out gracefully if it’s full...
 
21 - 24 of 24 Posts
Top