Nissan Frontier Forum banner
1 - 3 of 3 Posts

·
Registered
Joined
·
364 Posts
Discussion Starter · #1 ·
So I have an '03 CC V6 4x4 and have been having an issue with a misfire. I searched a few times on here, but never found an issue behaving like mine. If the truck sits overnight, it starts fine and will run without missing a beat as long as it stays running. If I turn it off and it sits for just a few minutes (3-5 minutes), it usually will start and run fine. If it sits for 10 minutes to 2 hours it will miss on cylinder 2 and the CEL will flash for about 3-4 miles, then it lines out and runs fine. I have replaced the spark plugs within the last year with NGK iridiums, and gas mileage isn't any worse than normal (15-16 in town). I am planning on getting a distributor car and rotor, but was wondering if there were any great ideas out here for me to check.
 

·
Registered
Joined
·
364 Posts
Discussion Starter · #3 ·
I have not done the wires yet. It just seems odd to me that after 2-3 miles of missing that it just quits missing and runs great.
 

·
Registered
Joined
·
364 Posts
Discussion Starter · #4 ·
I just wanted to follow up with this thread because I hate when I search and there is a list of problems like mine, but never a solution is listed. Mailman hit the nail on the head. It was the fuel injector. I had to wait until the problem got worse so I could test everything. Of course it was cylinder #2 under the intake plenum (at least it wasn't 4 or 6) so I could test it, but not replace it without taking the plenum off. Anyway I replaced it yesterday in about 1.5 hours and it runs perfect again.
 
1 - 3 of 3 Posts
Top