Nissan Frontier Forum banner

1 - 10 of 10 Posts

·
Registered
Joined
·
152 Posts
Discussion Starter #1
Hello everyone. Installed this morning new optima red top battery, check engine light came up as soon as i started the truck. any suggestions??? is there a way to pull up codes without a reader?

thanks

Nick
 

·
Premium Member
Joined
·
1,379 Posts
ive never heard that there was a correct polarity for batteries for our trucks....even for the optmia's. as far as i know as long as you hook up pos to pos and neg to neg your good....


for the check engine light, take it to any autozone/kragen/pepboys and they should beable to read your codes for free.. (unless your in cali.... they stoped doing it)
 

·
Registered
Joined
·
8,525 Posts
Thats my question. Did the OP purchase the correct battery. After reading a bunch of these battery threads, a common thing has come up, the 2nd Frontier is opposite then other vehicles like GM. I am just asking to confirm the OP hooked it up correctly.

It is a good question thou, will a vehicle fire-up if the battery is installed backwards?
 

·
Registered
Joined
·
152 Posts
Discussion Starter #6
no you can not start the car with polarities reversed. the battery is installed correctly. cel comes on but there are no problems while driving or idleing. i drove around 50 miles today and have not noticed any problems. could it be a possible alternator problem???
 

·
Registered
Joined
·
1,448 Posts
no you can not start the car with polarities reversed. the battery is installed correctly. cel comes on but there are no problems while driving or idleing. i drove around 50 miles today and have not noticed any problems. could it be a possible alternator problem???
If your alternator is not working, you will ultimately run the battery dead.

Try something simple. Disconnect the ground. Have a beer (15 minutes). Reconnect and see of the CEL clears.
 

·
Premium Member
Joined
·
1,892 Posts
Try something simple. Disconnect the ground. Have a beer (15 minutes). Reconnect and see of the CEL clears.

that was my thought. just dissconnect and let the system reset. yes, putting in a new battery, it should have reset during the process, but it can't hurt and is easier then running out to check a code. if it comes back, then have it checked

:noworries:
 

·
Premium Member
Joined
·
225 Posts
Installed my Optima Red Top a month ago and no issues.
 
1 - 10 of 10 Posts
Top