Nissan Frontier Forum banner

1 - 14 of 14 Posts

·
Registered
Joined
·
18 Posts
Discussion Starter · #1 ·
the other day I was fooling around with the 12v outlet on the dash on my 2008 nismo when I accidentally touched the red and black wires together from the back of the outlet. I was a dumb a$$ and I didn't disconnect the battery beforehand. there was a small spark and I quickly separated them. Now I don't have power to either. Checked the fuse and its not blown? Any ideas???:crikey:
 

·
Super Moderator
Joined
·
11,165 Posts
the above thought is a possibility and also tell us where did you check the fuses as there are a couple of locations for them.

Clint
 

·
Registered
Joined
·
18 Posts
Discussion Starter · #4 ·
I pulled the fuse at the fuse panel, held it up to the light looked okay. Swapped it for another, still nothing....
 

·
Registered
Joined
·
87 Posts
Possibly a Fusible link somewhere?????
 

·
Super Moderator
Joined
·
11,165 Posts
I pulled the fuse at the fuse panel, held it up to the light looked okay. Swapped it for another, still nothing....
under the hood or inside the truck?

Clint
 

·
Registered
Joined
·
1,258 Posts
I would say to make sure you have the correct fuse and then replace it with a new one. This happen to me and the fuse looked to be fine and was even one of the fuses that is supposed to light up when blown (didn't), but when I replaced it everything worked. Tiny damage to the fuse causes it to stop working. I believe the only fuse for this is in the box under the hood, I don't think there are any others.

Oh correction one of the outlets has a fuse under the hood and the other is in the box behind the glove box lid.
 

·
Registered
Joined
·
424 Posts
the other day I was fooling around with the 12v outlet on the dash on my 2008 nismo when I accidentally touched the red and black wires together from the back of the outlet. I was a dumb a$$ and I didn't disconnect the battery beforehand. there was a small spark and I quickly separated them. Now I don't have power to either. Checked the fuse and its not blown? Any ideas???:crikey:
You checked the wrong fuse, you checked the cabin fuse. Open the hood and check the 20 AMP (yellow) fuse in the fuse block under the hood. $5 says it's smoked. PM me with your congratulations. :laugh::laugh::laugh:
 

·
Super Moderator
Joined
·
11,165 Posts
How about your address to send the $5?

Clint
 

·
Registered
Joined
·
424 Posts

·
Super Moderator
Joined
·
11,165 Posts
Good to hear it's resolved and everything is working again. Due to the multiple fuse locations not everyone knows where to look.

Clint
 
1 - 14 of 14 Posts
Top