Nissan Frontier Forum banner

1 - 3 of 3 Posts

·
Registered
Joined
·
1 Posts
Discussion Starter #1
Just purchased a 06 Frontier king cab. Looking for awhile and bought from a used car lot in NJ. Almost made it home, 60 mile trip, when I noticed a loss of power.
Turns out it had a P0345 code. Cam sensor, it took me a while to find out where it was. I knew the L/F window didn't work, the A/C goes on and off and the tyre light is on.
Bought 3 cheap sensors off amazon and replaced the one that I needed. No good. Then my company sent me to California for 2 weeks. Just got back and started diagnostics again, which led to the same sensor or the ECU. Got a new sensor from the local auto parts store and now it works, 1-4 volts on the signal wire when running. Road test to pass monitors and now have a P0430 pending. I ordered a O2 sensor extension to rectify that.
 

·
Read Only
2019 Nissan Frontier PRO-4X
Joined
·
295 Posts
Just purchased a 06 Frontier king cab. Looking for awhile and bought from a used car lot in NJ. Almost made it home, 60 mile trip, when I noticed a loss of power.
Turns out it had a P0345 code. Cam sensor, it took me a while to find out where it was. I knew the L/F window didn't work, the A/C goes on and off and the tyre light is on.
Bought 3 cheap sensors off amazon and replaced the one that I needed. No good. Then my company sent me to California for 2 weeks. Just got back and started diagnostics again, which led to the same sensor or the ECU. Got a new sensor from the local auto parts store and now it works, 1-4 volts on the signal wire when running. Road test to pass monitors and now have a P0430 pending. I ordered a O2 sensor extension to rectify that.
Welcome to the Forums, and congrats on your new to you truck 👍
 
1 - 3 of 3 Posts
Top