Nissan Frontier Forum banner

1 - 9 of 9 Posts

·
Registered
Joined
·
5 Posts
Discussion Starter #1
I have a 2001 Frontier SE - not super charged. 161,000 miles. On a trip 2 years ago I got stuck in a traffic jam in hot weather 90+° and after the traffic flow resumed my truck was missing / stuttering under acceleration. This was just over 100,000 miles. Made it home and the next day the truck ran fine.

A few days later the miss and stutter returned in hot weather after the truck had been driven a while. Again after getting home and letting it sit it would run fine for a while and then when hot would miss and stutter again. No check engine light at any time.

Took it in to my mechanic and with nothing to go on (no check engine light or codes) we decided to go for three things. It was time to replace the timing belt so we did that as well as changing plugs and distributor. Also cleaned the MAS. My mechanic uses a service where other mechanics report problems and their success in solving them. Several had reported miss / stutter as being solved by replacing the distributor. Put on an aftermarket distributor that cost $250 with a 1 year warranty. Everything seemed well but it was moving into fall weather with cooler temps.

Fast forward 15 months and the miss and stutter returned at 130,000 miles again in hot weather. As we had what we thought was good luck with the distributor change previously we decided to change again. This time I got a $67 one off ebay. It did not fix the problem. Changed the spark plug wires with good quality replacements and the distributor again with a better quality one with a lifetime warranty. Still did not fix the problem. Now I had check engine light for multiple issues.

Found the knock sensor issue here and decided to try the relocation. Got the 1999 Maxima harness and sensor and did the relocation. Cleared all codes. Did not fix the problem but I have no check engine light and have driven it for two days.

The miss and stutter begins under hard acceleration. It is a hard miss / stutter that gets worse the more the truck is driven. It will eventually get so bad that it is hard to maintain 55mph as the miss will start to happen under any acceleration. It will exhibit the symptom while sitting still, in gear, with foot on the brake and put under load. It runs better in cooler morning weather. This miss and stutter is rhythmic as in under hard acceleration it is like miss, miss, full acceleration, miss, miss, full acceleration.

I'm thinking I may have a bad plug but I would think it would CEL and code to which plug is misfiring. With the rhythmic pattern of the miss I don't think it's fuel related.

Truck does not have any other issues and has been well maintained.

I need some ideas of what may be the issue and what diagnostics may verify it. Other than that I'm stuck with taking it to a Nissan dealer 1½ hours away and hoping that they can find the issue without blaming the knock sensor relocation.

Any thoughts are welcomed.

Thanks guys
 

·
Registered
Joined
·
674 Posts
Check your fuel pressure with engine off key on, at idle, and when the miss is happening. My guess is you have a fuel pressure issue, if you've changed the filter then I would think you'll have below spec pressure when it's warmed up and working because of a corroded fuel tank base or lazy fuel pump

Sent from my XT1080 using Tapatalk
 

·
Registered
Joined
·
79 Posts
Since it's rhythmic, it may be a bad fuel injector. Hook up a vacuum gauge to it, it will show if there's any engine problems.
 

·
Registered
Joined
·
5 Posts
Discussion Starter #4 (Edited)
I've attached a video of the miss / stutter at it's worst. This only happens in hot weather after the engine warms up. You can see that I'm only going about 45mph with about 3/4 throttle. I am not pumping the gas pedal. It is surging on its own. You can see that it is rhythmic. Still fuel thoughts?

https://youtu.be/ioY7f8MlhVY
 

·
Registered
2015 CC SL 4x4 - Lear Cap.
Joined
·
231 Posts

·
Registered
Joined
·
5 Posts
Discussion Starter #7
Got the diagnosis for the problem. Rusted fuel tank and under pressure fuel pump. Tank, pump, sender and install = $1,480. I'm going to do it myself. The level sensor hasn't been reading empty correct so I'm going to replace it while I'm in there.

So I need:

Tank 17202-5S620
Pump 17042-4S400
Level sensor 25060-4S415
O-ring 17342-01A00
Fuel gauge retainer 17341-40U00
Fuel filter 16400-0W005

Have I missed anything?
 

·
Super Moderator
Joined
·
3,188 Posts
You might want to get new bolts for the retainer. They have a tendency to rust and break. You may also want to change any hoses while you are there. The ones on my 2001 were pretty dry rotted the last time I changed my fuel filter. Probably wouldn't hurt to have some fuel injection hose clamps on hand, as well.
 

·
Registered
Joined
·
132 Posts
You might look at Rock Auto. They might have many of those parts for way less. I got an aftermarket gas tank for my son's Accord and it was WAY less expensive and worked perfectly. Just my $.02

Sent from my SCH-I545 using Tapatalk
 
1 - 9 of 9 Posts
Top