Nissan Frontier Forum banner

1 - 5 of 5 Posts

·
Registered
Joined
·
9 Posts
Discussion Starter · #1 ·
I hope this question hasn't been asked before. I did a quick search and didn't find it yet. The truck is an 07 extended cab automatic with the 4.0L. The other day I used it to jump start my neighbors car. When I started to drive back to the house it went into limp mode. It acted like it did when the TCM got coolant on it. I figured it blew the TCM fuse for whatever reason. Parked the truck and checked every fuse inside and out including relays and found everything to be fine. Most of the electronics work but its no crank no start. Most of the fuses in the IPDM have power going to them. A few don't. I did the auto active test a few times but it only gave me 5 or 6 long flashes. Before I reset the computer I managed to get a p0603 code with my scanner. From what I've read it sounds like the PCM fried. Does anyone know of some tests I can do to see if it's getting power? I have a volt meter I just don't know which wires to test. If I bring the PCM to a Nissan dealer can they test it? I just like to rule out as much as possible before going to a shop. Thanks in advance for any help on this.

I forgot to mention I got the truck used and don't know if any of the recalls were done to it.
 

·
Super Moderator
Joined
·
19,907 Posts
I hope this question hasn't been asked before. I did a quick search and didn't find it yet. The truck is an 07 extended cab automatic with the 4.0L. The other day I used it to jump start my neighbors car. When I started to drive back to the house it went into limp mode. It acted like it did when the TCM got coolant on it. I figured it blew the TCM fuse for whatever reason. Parked the truck and checked every fuse inside and out including relays and found everything to be fine. Most of the electronics work but its no crank no start. Most of the fuses in the IPDM have power going to them. A few don't. I did the auto active test a few times but it only gave me 5 or 6 long flashes. Before I reset the computer I managed to get a p0603 code with my scanner. From what I've read it sounds like the PCM fried. Does anyone know of some tests I can do to see if it's getting power? I have a volt meter I just don't know which wires to test. If I bring the PCM to a Nissan dealer can they test it? I just like to rule out as much as possible before going to a shop. Thanks in advance for any help on this.

I forgot to mention I got the truck used and don't know if any of the recalls were done to it.
Did you check the fuses on the positive battery cable by the battery?
 

·
Registered
Joined
·
9 Posts
Discussion Starter · #4 ·
I need to edit a bit. I tried the auto active test and it did nothing. And when I pulled the codes using the trick with the gas pedal depression system is when I got the 5 or 6 flashes.
 
1 - 5 of 5 Posts
Top