Nissan Frontier Forum banner

1 - 1 of 1 Posts

·
Registered
Joined
·
1 Posts
Discussion Starter #1
Hi members. I purchased a 2012 4x4 SV a couple of months ago. Within the last couple of weeks, the check engine light came on. Scanner called out code P0101, which I have read about....is a pretty common indicator. No issues with starting or driving, I was advised to keep an eye on the Mass Air Flow Sensor. The light came on again a couple of days later (again no issues with starting or driving) and I took steps to clean the Mass Air Flow Sensor. A couple of days later, after the truck was parked for most of the day, I went to start it and it would not. No issues with the battery. Since it happened at work, I had called a tow truck service. The operator disconnected the battery terminal, reconnected and then ran the obdII scanner. The truck started right up and I was able to drive home. Took the truck to a local repair shop and for the entire day the truck was there, it started with no issues and no check engine light. After picking it up, another day or so, the check engine light came on. I decided to change the Mass Air Flow Sensor and I also purchased a obdII scanner. After a week or so, the check engine light has not come on. However, what has been happening, is that the truck will not start. Again, fully charging and healthy battery. By accident, I hooked up the obdII scanner to see if anything was being identified as an issue. Nothing came up, but when I started the truck, it started right up! Over the last couple of days, the truck does not start (mostly after sitting for awhile), but will start if I run the obdII scanner. Has anyone experienced something similar to this? Thoughts on what I should do? Sorry for the long message, wanted to be as descriptive as I could. Thanks again!
 
1 - 1 of 1 Posts
Top