Nissan Frontier Forum banner

1 - 8 of 8 Posts

·
Registered
Joined
·
6 Posts
Discussion Starter #1
Hello forum members!

My name is Rob and I drive a 2000 Nissan Frontier King Cab XE 2.4L 4-cyl. 5-speed Manual.

Cheers!
-Rob
 

·
Registered
Joined
·
6 Posts
Discussion Starter #2
Prohibited from posting?

I posted this thread in the new members section and yet still can't contribute or post on other forums. I guess for the moment I'll mention why I joined in this thread. I'm hoping to get some advice on some new noises coming from my engine compartment. Each time I start my vehicle I get a guttural groaning noise while the engine warms up. After a certain point it goes away and the truck runs normally. The noise has been starting to stay longer and become more pronounced so I'm really not sure if this is something serious. The truck has just under 90 k miles and has been running smoothly since I've purchased it in 2010. Last repairs were a fan and compressor belt changes and a new ball bearing for one of the pulleys. Additionally, I recharged the AC a few months ago. Any help or advice is greatly appreciated! Hopefully I'm not stuck with a major repair...
 

·
Registered
Joined
·
266 Posts
its recommended to log out and back in. it took me a while to be able to post. But hopefully it will activate soon. Glad to see another member from Indiana!
 

·
Registered
Joined
·
45 Posts
Welcome, I had the similar problem when trying to post as well. Logging out and back in helped. Like Street Sweeper mentioned, it's good to see another from Indiana!
 

·
Registered
Joined
·
6 Posts
Discussion Starter #6
Thanks gents. I've gone through a cycle of logging in and logging out so hopefully that works.
 
1 - 8 of 8 Posts
Top