Nissan Frontier Forum banner

1 - 4 of 4 Posts

·
Registered
Joined
·
9 Posts
Discussion Starter #1
Hi All,

I have been lurking around the forums for a few months now but hope to become more active as my time with my truck progresses.

Last fall I bought an '05 DCSB SE 6spd MT with 165,000kms on it. The truck was in fairly good shape for its age and I really wanted a 6spd MT short box so I pulled the trigger, it also just had the clutch replaced.

I am still working through a large list of regular maintenance items I want to do before the mods happen:
- Change diff fluid and transfer case fluid - DONE
- Coolant Flush - DONE
- Replace damaged cone filter on air intake - DONE (Came with K&N Intake)
- Change loud Banks Exhaust - DONE (got a Walker Quiet Flow kit from Rock Auto and I love it!)
- Fix broken tailgate hinge - DONE (updated with 2014 hinge)
- Get keys for canopy locks - DONE
- Change spark plugs
- Fix squeaky pulley
- Fix ABS/Slip light issue - Replaced rear wheel speed sensor but still not fixed (suggestions would be great!?)

Mod Plans (Short Term):
Top priority is to get it out of the weeds, also my rear suspension is rusted out.
- OME leaf pack and Bilstein 5100 in rear
- 2" spacers for the front
- 33" tires for stock wheels (keeping an eye out for Pro 4X wheels)
- LED light bar
- Upgrade headlights (not sure what I want to do yet)
- LED tail lights
- Tonneau cover for bed
- Pre-Runner front bumper

I am sure more will come up, anyway thanks for reading.

Some Pics for Clicks
 

Attachments

·
Premium Member
Joined
·
6,101 Posts
Nice find! You done found the right place to spend a lot of your hard earned money...we can help!

FYI/FWIW - hope that dual-mass flywheel was also replaced w/ clutch job...as these cannot be resurfaced.
 

·
Registered
Joined
·
9 Posts
Discussion Starter #3
Yeah, I hope so as well.....I believe it was i'll have to dig out the invoice that he gave me showing the work.

Any ideas with the ABS/SLIP lights, I have read a bunch of posts about it but none that really help.

My problem is intermittent, the lights will go on and off without any real noticeable cause. I did scan the truck and it showed that the passenger rear sensor was causing the issue so I ordered a new one from Rock Auto and replaced it because the axel seal on that side also needed to be replaced, cleared the codes an then they came back after about 45 minutes of driving.

I have checked my brake fluid, checked for leaks, wheel bearings seem fine. Need to re-scan to find the new fault.
 

·
Premium Member
Joined
·
6,101 Posts
Post your question where it will be read by more folks. Pretty sure many skim past this intro area.

Enjoy your 6-sp w/ new clutch!
 
1 - 4 of 4 Posts
Top