Nissan Frontier Forum banner
441 - 460 of 460 Posts

·
Registered
Joined
·
1,017 Posts
Just received mine after a long wait. Passenger side low beam dead. Everything else worked. Has the external relay taped/ bolted on. I'm assuming it's the relay from reading this thread but don't feel comfortable bypassing it under warranty. Have had good experience with TRS on replacements before but pretty disappointed considering the price and time spent on this. Might just return and stick with the katanas.
The QC and light output does not seem to be great with these. I was considering them for awhile but I'm glad I decided to do my own retrofit.
 

·
Premium Member
2020 SV Midnight Edition 4x4
Joined
·
326 Posts
I pulled the trigger on the Morimoto's this morning. Never really planned on upgrading my lights, but after seeing how good they look I just couldn't resist.
 

·
Registered
Joined
·
1,784 Posts
On the way home.... gave out.... drivers side...🙄 it's flickered only a few times since the install....
 

·
Registered
Joined
·
730 Posts
I've been fortunate as I've not experienced any of the flickering or soaked relay issues to-date. I installed my Morimoto headlights in mid-August. Hearing of other members' experience, I continue to hold my breath. Sorry you're having to experience these issues but I'm sure they will back their warranty and make good on the product. (they better)
 

·
Registered
Joined
·
1,784 Posts
Going to call Z1 shortly and report it. Thinking of doing the relay delete, but want to document with Z1 first the problem, and perhaps a solution.
 
  • Like
Reactions: Zero Six LE

·
Registered
Joined
·
1,784 Posts
Just spoke with them and documented the issue. He said that it's still under warranty, but would be dealt with Morimoto as far as getting a new pair. He did mention that people are having this issue with moisture getting inside the relays and that people are mounting them vertically for a fix.... will try and see if I can do this myself... looks pretty straight forward for the relay delete...... I had so much hope and hype for these..... ugh!:rolleyes:
 
  • Like
Reactions: Zero Six LE

·
Premium Member
2019 Black PRO-4X 6MT
Joined
·
589 Posts
Just spoke with them and documented the issue. He said that it's still under warranty, but would be dealt with Morimoto as far as getting a new pair. He did mention that people are having this issue with moisture getting inside the relays and that people are mounting them vertically for a fix.... will try and see if I can do this myself... looks pretty straight forward for the relay delete...... I had so much hope and hype for these..... ugh!:rolleyes:
I truly can not figure out why they insist on the relays and shipping the lights with them. It serves no purpose except to limit the low beam to ignition. The question though is WHY? The high beam is not limited to ignition. You can turn the morimoto high beam on when the truck is off, but not the low beam. The factory low beam halogen is not limited to ignition. Why do we need this? Makes no sense to me. I definitely hear ya not wanting to mess with the relays due to warranty reasons but I didn't want to deal with warranty which is why I went ahead with it. I'm really surprised that Morimoto's solution on the new headlights is to screw the relay to the housing rather than to just ditch it completely. It's more work for them as a manufacturer, more wiring clutter, more physical parts needed to purchase, and all for an added failure point that clearly fails often. I just don't get it.

I'm just glad the problem is this simple and isn't an LED component actually going bad. If I have failures like that, that's when I'll get more pissed because I'll actually have to do the work to swap them off and on again with the replacements, which is a pain I don't want to deal with.
 

·
Premium Member
2020 SV Midnight Edition 4x4
Joined
·
326 Posts
So my Morimoto's arrived yesterday and I'm itching to get these in this installed this weekend if I can. I don't want to deal with a failed "relay" after installing them but I also don't want to void any warranties due to modifications. I'm going use "liquid electric tape" to try and seal things up a bit and then mount the relay vertical as suggested by the vendor and brought to light here by @RobFrisco415 .
 

·
Registered
Joined
·
1,784 Posts
Operation Relay Delete (ORD) completed! :D Thanks @RedKing4x4 for the write up! Soldered the 3 blacks together, blues together, and brown & orange..... and wallah! Everything works and flicker is gone! BOOOOYAHHHHH!!!!!! :cool:
 

·
Registered
Joined
·
730 Posts
good job. update us if anything changes in performance.

I'll wait until after the warranty period to consider mods. It's amazing the technological changes related to vehicle lighting the past few years. If you're not familiar with this, look up LEP (laser excited phosphor) which BMW and few other manufacturers are beginning to use. I've seen a couple of flashlights using this design and am intrigued but we're still years away from retrofitting this to existing headlights.
 

·
Premium Member
2019 Black PRO-4X 6MT
Joined
·
589 Posts
All that wait time and all I see is issues!
All you’re seeing is 1 issue 20x. Not standing up for Morimoto or defending them, they need to fix this, but you’re seeing one problematic problem happen to nearly everyone who bought them. It’s not like the lights are finding a new way to fail every day.

It’s surprisingly reminiscent of SMOD. One very common problem, affects many of the vehicles produced from that era, but it’s still just one common problem. Bypass it or come up with a better solution like replacing the radiator but it’s still one issue that is the root problem.
 

·
Registered
2016 SV, 4WD, CC, 6MT, Volant CAI, Bullydog GT, Flowmaster Super 10
Joined
·
10 Posts
Just ordered my set. Hopefully they dont take too long to get here. Ill probably go ahead and seal up the relays once I get them.
 
441 - 460 of 460 Posts
Top