Nissan Frontier Forum banner

1 - 12 of 12 Posts

·
Registered
Joined
·
283 Posts
Discussion Starter #1
Hi all,

Wanted to see if anyone else out there has had a problem with their moonroof.

I'm having a problem with the tilt function of it, it will tilt up, but when I hit the button to go down, it doesn't always go down the first time. I often have to hit it multiple times for it to go down or hit the down button and then quickly hit the slide button. Although the 2nd option doesn't always work the first time either.

The slider function works fine.

Any input would be greatly appreciated.

thanks,
jegonzo3
 

·
Registered
Joined
·
1,560 Posts
Hi all,

Wanted to see if anyone else out there has had a problem with their moonroof.

I'm having a problem with the tilt function of it, it will tilt up, but when I hit the button to go down, it doesn't always go down the first time. I often have to hit it multiple times for it to go down or hit the down button and then quickly hit the slide button. Although the 2nd option doesn't always work the first time either.

The slider function works fine.

Any input would be greatly appreciated.

thanks,
jegonzo3
Does this occur while stopped or at highway speeds?

If while stopped, not sure what the issue is. If while at highway speeds, not sure how to properly fix the issue, but if you drop any other window in the truck slightly prior to attempting to close the tilt, it will close for you. It's a pressure issue.

I think there is some way to make it relearn things. I don't know what this way is.

The other thing I have had success with is simply holding the tilt close button until it closes.

ymmv
 

·
Registered
Joined
·
283 Posts
Discussion Starter #6
It has been while I've been stopped and at various speeds.

Holding the button only cycles it, from open to closed and back to open, never stopping in between (meaning closing and staying closed).

jegonzo3
 

·
Registered
Joined
·
1,560 Posts
hold please, searching....

Found it:

Per smizwhiz with 142 posts at the time:

According to the service manual, the procedure below is always the first step in trying to fix sunroof problems. Give it a shot and see what happens. If it doesn't work, I think you'll either need to get a factory service manual as the troubleshooting is tedious, or take it to the dealer.

INITIALIZATION PROCEDURE
If the sunroof does not close or open automatically, use the following procedure to return sunroof operation to
normal.
1. Turn ignition switch ON.
2. Push and hold the sunroof tilt switch in the forward (DOWN) position until the sunroof is fully closed.
3. After the sunroof has closed all the way, push and hold the tilt switch forward (DOWN) again for more than
2 seconds to re-learn motor position.
4. Initialization is complete if the sunroof operates normally.
Not sure if this will help your situation, but I don't see how it can hurt it.
 

·
Registered
Joined
·
1,149 Posts
I had to do a similar fix for the wife's quest. Worked like a charm afterwards. I did have to take the door off and push a stupid learning button, almost decapitating my finger while closing it! Please let us know if it works!
 

·
Registered
Joined
·
209 Posts
I've had a similar problem. For me, I noticed it when I would leave the sunroof tilted over night or while parked to keep the truck vented. I think either something is gumming up the works in the "rails" or some kind of tension has been built from prolonged rest that the motor can't overcome it.

Here's what works for me: Start to close the tilt feature then stop it right before it would bounce back up (almost flush or neutral position). After letting it rest in this position for some time, then attempt to "close" it all the way to the neutral resting position. Even in this "partial" close position it should appear pretty flush. It won't be watertight, but it should be good enough for everything else. This method has worked for me many times. Living in this heat, I like to try and keep my BLACK truck vented while parked at work or a quick run to the store. Good luck and I hope this helps!

(YMMV, but try to open a window so there isn't an "air" seal in the vehicle when closing the sunroof)
 

·
Registered
Joined
·
283 Posts
Discussion Starter #12
Hey guys, I got it to work properly.

One thing I forgot to mention in my original post, is that when it did open, it made a rather loud noise, but not sure where it was coming from. Maybe the gears not being on track properly.

Anyways, I went out and tried a few of your suggestions, but one thing I did do was push up on it when it was in the up position. Once I did that, it started working fine and the noise went away. It opened and closed smoothly.

I'll keep trying it out the next few days to make sure it still works properly.

jegonzo3
 
1 - 12 of 12 Posts
Top