Nissan Frontier Forum banner
1 - 3 of 3 Posts

·
Registered
Joined
·
77 Posts
Discussion Starter · #1 ·
Got a 2002 v6 cc and has started to get a bad miss at an idle. It only does it when you have it in gear stopped at a light or something. Never misses a lick when in park or driving. I noticed a loud click like a solinoid or something when it misses from under the hood but could not pin point it while holding the truck in drive and listening. I dont have any mods other than a K&N filter and air box mod.It does not do it all the time but seems to be getting worse.Doesnt matter if its cold or warmed up. It is a solid dead miss to,the whole truck bumps when it does it.Im gonna replace plugs,wires and cap and rotor today but have a feeling its not gonna solve it. It kinda sounds like a common prob here on the board so where do I turn next? I already cleanEd the MAF with no luck.Should I replace the distributer while im at it? Its got 107,000 miles on it.
 

·
Registered
Joined
·
260 Posts
If your maintenence doesn't work, I would look to a clogged or faulty injector next. Check out the factory service manual for instructions on how to ohm test them. There is a download link for the FSM at the top of the DIY section of the forum. You could also have a dealership run a "power balance" test to pinpoint the dead cylinder - or you could try measuring the temperature of each leg of your exhaust manifolds with an IR thermometer and look for the colder one. Harbor Freight has one for about $40 and it's a cool tool to have on hand anyhow. :D

Is your timing belt up to date? A slipped tooth can do all sorts of weird things - probably would feel worse than you describe though.

Heath
 
1 - 3 of 3 Posts
Top