Nissan Frontier Forum banner

1 - 5 of 5 Posts

·
Registered
Joined
·
5 Posts
Discussion Starter #1
I replaced the seals on both sides on the back of my 2006 Nissan Frontier 4x4 NISMO about a year ago, maybe 15,000 miles but probably closer to 10,000. Over the weekend I slightly used my rear differential lock and 4WD H. When I got home that night I smelled something weird looked under the truck and noticed fluid slung all over the new wheel and tire I got a few months back on the passages rear. The next day a puddle had collected under that tire. Anyone experienced this before? Is there a preferred seal to use? Your help is appreciated!!


Sent from my iPad using Tapatalk
 

·
Registered
Joined
·
5,999 Posts
Don't say stuff like this. I replaced my rear axle seal about 5K ago. Hope mine doesn't leak. I used OE nissan seals. I recall the job being straight forward but a little hooky. Easy to screw up and tear the seal or have a bad rusted and pitted sealing surface.
 

·
Registered
Joined
·
170 Posts
Yeah, you probably ripped the new gasket/seal. Did you torque down all bolts?
 

·
Premium Member
Joined
·
12,051 Posts
i did the both sides of mine a few years ago, maybe 20k or more ago and everything is still perfect.
i used some race bearing application from 4x4 parts, supposed to be better fit and quality than oem.
i think i used oem seals too.
 

·
Registered
Joined
·
5 Posts
Discussion Starter #5 (Edited)
Yeah, you probably ripped the new gasket/seal. Did you torque down all bolts?


I did torque them down. Maybe its just a fluke.....I hope.


Sent from my iPad using Tapatalk

i did the both sides of mine a few years ago, maybe 20k or more ago and everything is still perfect.

i used some race bearing application from 4x4 parts, supposed to be better fit and quality than oem.

i think i used oem seals too.


I will check on that see if I can replace with a better part.
Thanks!


Sent from my iPad using Tapatalk
 
1 - 5 of 5 Posts
Top