Nissan Frontier Forum banner

1 - 11 of 11 Posts

·
Registered
Joined
·
2 Posts
Discussion Starter #1
i'm getting a knocking in the front passenger wheel on my 2007 frontier SE. i'v already replaced the ball joints, strut and spring, you name it. still getting a knock every time i hit a bump in the road. any ideas would be appreciated.
 

·
Registered
Joined
·
2,282 Posts
End Links? Sway Bar bushings? Strut assembled correctly?
 

·
Registered
Joined
·
929 Posts
I'll second invasion08 sway bar links. Sometimes you need to disconnect one of the links to test them, as a slight tension on the bar will keep them both tight.

Someone was on here within the last week, same issue, turned out to be defective Bilstien shock. Did this noise start after replacing strut?
 

·
Registered
Joined
·
2 Posts
Discussion Starter #4
no. i started replacing parts because of the noise. end links, new strut and spring, ball joints. hasn't done anything to help the knocking
 

·
Registered
Joined
·
929 Posts
Don't be replacing parts that don't need replacing.
Recheck your work that's been done.
Also back off the axle nut one turn, then lube and re-torque it.
Check brakes and caliper bracket.
Then start looking elsewhere, like loose body parts/battery/muffler/glove box contents/seat and seat belts, etc.
 

·
Registered
Joined
·
450 Posts
Tie rod ends maybe? I have a clunking noise on mine when I turn the wheel left and go over a bump or anything,sounds like a loud pop. I should have fixed it when I was doing my ball joints but I fought those so hard I didn't have it in me, plus I needed the truck back on the road the next day. Was painfully obvious when I went to tighten it back down n it just kept spinning, so I put some tension n was able to get it torqued. Was thinking of bringing it in the garage n at least start with the outers for now. I at least am certain it's my tie rod, could very well be something else with my luck. Used to only happen in wet conditions but now it's all the time

Sent from my Pixel 3a XL using Tapatalk
 

·
Registered
Joined
·
105 Posts
I had a noise on my truck same location. It was the bumper retainer/support rod. The nut had slipped and the flange was in the slot at the top. I just loosened the nut and made sure it was centered up and down in the slot. I really need to go back and add a larger washer instead of relying on the flange nut because I'm pretty sure it's starting again.
 

·
Registered
Joined
·
450 Posts
I had a noise on my truck same location. It was the bumper retainer/support rod. The nut had slipped and the flange was in the slot at the top. I just loosened the nut and made sure it was centered up and down in the slot. I really need to go back and add a larger washer instead of relying on the flange nut because I'm pretty sure it's starting again.
I am guessing you have the metal bumper? Was under there inspecting my outer tie rods n didn't see this rod. Turns out my tie rod ends are beyond shot

Sent from my Pixel 3a XL using Tapatalk
 

·
Registered
Joined
·
450 Posts
Here is the video. First link is passenger side n second is driver side. The squeaking is from the gloves.



Sent from my Pixel 3a XL using Tapatalk
 

·
Registered
Joined
·
105 Posts
I am guessing you have the metal bumper? Was under there inspecting my outer tie rods n didn't see this rod. Turns out my tie rod ends are beyond shot

Sent from my Pixel 3a XL using Tapatalk
Yes I've got the two piece chrome bumper, seems the Nismos came with steel where the pro4x come with plastic
 

·
Registered
Joined
·
559 Posts
Check the body mount plate just behind the passenger front tire. I had a knocking that ended up being that.
 
1 - 11 of 11 Posts
Top