Nissan Frontier Forum banner
1 - 5 of 5 Posts

·
Registered
Joined
·
9 Posts
Discussion Starter · #1 ·
I have a Nissan Frontier 2007 4x4 nismo with 150k on the odometer.

The issue with the truck is that when sitting for over a hour or maybe a little less the truck starts fine and runs well too, but if I turn the truck off after driving it for 10 mins to whenever time.. get out, do something then come back to the truck about 5 mins later it starts up, but revs about 1500 then right after try?s to die and bog out. The mechanic said he did some kind of ?fuel treatment? but it?s still acting up. Anyone ever had this issue before? He also said the fuel filter is changed.
 

·
Registered
Joined
·
340 Posts
This has happened to me on many nissans. My only guess was the vehicles run really rich on startup. Maybe some fuel doesn't get burned or something. After awhile of cranking and playing with the gas pedal I am usually able to get it to start but it reeks of unburnt fuel. I smell it out of the exhaust and in the engine bay.

Only way for me to prevent this is to make sure I bring the vehicle up to temp before shutting off.
 

·
Registered
Joined
·
675 Posts
No I haven't with the frontier did you just fill up before this happened that would lead me to believe fuel is bad or water

But I have a few ?'s
You said a 2007 how did mechanic replace your filter I wasn't aware of 1 on our pu? did he change your pump???. I really didn't think we had a fuel filter in the traditional sense per say I know there isn't one in my engine bay or on rail going back think all we have is a screen on pump but haven't dropped my tank so cannot answer for sure. I only ask cause I have 2010 I don't have one

You have no illuminated mil have you checked for stored codes?

From what you describe it kinda sounds also like maybe your regulator or vapor lock or maybe yours cannot compensate enough try checking air also like your MAF but I'm only guessing here cause I cant see your pu an what its doing. Have you checked the fuel pressure also before after you shut it an the drop and build you can also try chasing after a leaky fuel injector too while your at it but with that shouldn't matter hot or cold you'd see/smell it on the plug.

You said 150k now when driving down the road have you noticed after it gets warmed up and your running it does it wants to die not go any faster anything?

What type of service was done on fuel? when Ive used a injector or fuel cleaner in a can I only used Chevron or Berryman in my vehicles

Good luck keep us posted Ill think some more on it also
 

·
Registered
Joined
·
9 Posts
Discussion Starter · #4 ·
Ok I?m back and I have done a few things since the dealership is not helping me out anymore. I have replaced crank shaft sensor and can shaft sensor. Just a hour ago I cleaned the throttle body and I have cleaned the mafs. I?m going to see what happens when I goto work tomorrow and play with the issue of restarting the engine.

I have noticed a slight gas smell inside the truck. Smells like it?s coming through the vents but this is only when I get off the high way from 10 miles. Then the smell goes away. I tried to locate where the possible leak is but cannot see or smell anything.

What about the fuel pump, does this have and affect of restarting the engine then bogging down if the pump is no good?
 

·
Super Moderator
Joined
·
3,839 Posts
He saying the fuel filter is part of the fuel pump module inside the gas tank; there is no serviceable fuel filter on the vehicle from the factory. I caught that too while reading your post and questioned it.
 
1 - 5 of 5 Posts
Top