Nissan Frontier Forum banner

1 - 8 of 8 Posts

·
Registered
Joined
·
9 Posts
Discussion Starter #1
I've read a bunch of threads on these particular subjects but I figured Id see what you all thought before I take my truck to the dealership.

Up until Sunday, I haven't had any issues with my truck. I stopped at my house to drop off a trailer, shut off the truck and when I went to start it back up, it sounded like it was starving for fuel or air and eventually shut off. Then it wouldn't start at all.

I first checked the fuses and everything is fine. Had gas in truck. Put a scanner on it and it threw no codes. Read about the ecm relay and replaced that. Still no start. Dropped the fuel tank to check the fuel pump and I'm not getting fire to the pump.

Now my engine fan runs when I turn the key on but not start and I have a bunch of abnormal lights on in my dash like my 4x4 light and slid light.

I Just tried the scanner again and it's not even recognizing the system to check it. It sounds like a faulty ipdm but it could also be the ecm. Could even be both...I guess I just need a push in the right direction.
 

·
Registered
Joined
·
276 Posts
Just a question but what year and how many miles is on your truck? I'll pm you

Sent from my SCH-R970X using Tapatalk
 

·
Registered
Joined
·
276 Posts
I pmd u

Sent from my SCH-R970X using Tapatalk

Hey man if u want u can download tapa talk. It helps out a lot of these forums instead of having to check a site

Sent from my SCH-R970X using Tapatalk
 

·
Super Moderator
Joined
·
3,333 Posts
Default mode for an ECM problem is to turn the cooling fans on. It sounds like there is no communication to the ECM. What you should do is get a copy of the EC (engine control) section of the factory service manual for your vehicle (try NissanHelp.com's knowledge base or NicoClub.com for downloadable manuals) and follow the diagnostic steps for no start and/or no communication to the ECM. This will give you the proper order of things to check and will include wiring diagrams and such to help you isolate the cause of the problem.
 

·
Registered
Joined
·
9 Posts
Discussion Starter #7
I found where it says you need to check if the ecm is receiving power and you back probe certain wires to find out but the wire harnesses are covered by the latching system and it looks like something I don't want to tamper with too much and break it.

Just for a gamble I pulled a used ipdm from a 2010 frontier at the junkyard (t's suppose to be a more updated one 284b6-ze03b) and tried to start the truck up. I am aware that the newer ipdm could be faulty but I was willing to try anyways. Still doing the exact same thing as the old ipdm.

Sent from my SM-G920V using Tapatalk
 

·
Registered
Joined
·
9 Posts
Discussion Starter #8
Took it to the dealership and apparently the ecm shorted out so it has to be replaced. Has there been any known problems with the ecm??

Sent from my SM-G920V using Tapatalk
 
1 - 8 of 8 Posts
Top