Nissan Frontier Forum banner

1 - 10 of 10 Posts

·
Registered
Joined
·
3 Posts
Discussion Starter · #1 ·
Hi everyone. I am from the Philippines, I was looking for a interaction group to help me answer my questions with my Nissan Navara pickup truck. Hope I could hear experiences that may be helpful. -Jayden
 

·
Registered
Joined
·
1,190 Posts

·
Admin
Joined
·
3,392 Posts
Welcome Jayden!
 

·
Registered
Joined
·
3 Posts
Discussion Starter · #7 ·
Hello guys, Its quite frustrating that haven't used this car this much and and after awhile problems arise one after the other. At 75K mileage, the truck experienced low power and even to the extent of shutting the engine in the middle of a drive. I went to Nissan Center and advised to change oil and replace air, oil and fuel filters but to no avail after having it do. What is wrong? Can't the center diagnose it correctly and have it fixed......Frustrating..... The problem was solved however by cleaning the EGR valve but to another local shop run by my friend. Just 2 weeks ago the mileage marked at 80K and another problem had arise. Truck again experienced low power but with "check engine indication" on the front panel. I started to reset the ECU by following the steps on the forum but didn't work out. I decided again to go to Nissan Center to have the error downloaded. They told me that an estimate was about $4.3K to have it fixed because of the defective Injection pump system. I began to wonder..Do they have a correct diagnosis of my truck or they just applying a miss or hit option. I pulled out my unit from the shop after replacing the fuel filters but on the brighter side error indication was reset but still with no power. I gambled yesterday to change the suction valve electronic unit hoping it was the problem but later found out that I still haven't fix it. Any advise guys...Im afraid I may lose options, sad to say even the shop center cant make a pinpointed diagnose of the problem. Please help me guys. I have attached pix of my unit.
 

Attachments

·
Registered
Joined
·
1,190 Posts
Sorry people on the internet are going to be shooting in the dark even more so than a shop you visited. Can you please provide the ECU trouble code that was stored? That helps a lot. Sorry for you troubles.
 

·
Registered
Joined
·
741 Posts
Need to know the code the CEL threw to start with...
 

·
Registered
Joined
·
3 Posts
Discussion Starter · #10 ·
The ECU has a on board diagnostic system that detects any malfunctions of engine sensors and actuators if the MIL starts to light up, but i tried the steps in downloading the error code (I have attached the file below for reference) but just couldn't get through the diagnostic mode. Am i using the correct steps in going to the "diagnostic mode"?

STEPS TAKEN:

How to Set Diagnostic Test Mode II (Self-diagnostic Results)
1. Confirm that accelerator pedal is fully released, turn ignition switch ON and wait 3 seconds.
2. Repeat the following procedure quickly five times within 5 seconds.
a. Fully depress the accelerator pedal.
b. Fully release the accelerator pedal.
3. Wait 7 seconds, fully depress the accelerator pedal and keep it for approx. 10 seconds until the MI starts
blinking.
4. Fully release the accelerator pedal.
ECM has entered to Diagnostic Test Mode II (Self-diagnostic results).

How to Erase Diagnostic Test Mode II (Self-diagnostic Results)
1. Set ECM in Diagnostic Test Mode II (Self-diagnostic results).
Mode II (Self-diagnostic Results)" .
2. Fully depress the accelerator pedal and keep it for more than 10 seconds.
The emission-related diagnostic information has been erased from the backup memory in the ECM.
3. Fully release the accelerator pedal, and confirm the DTC 0000 is displayed.

or in short
Ign on count to 3
full on and off throttle 5 times within 5 sec's
count to 7 hold throttle down for 10 or so seconds
wait for the ECM light to flash let go of throttle and your in count the codes after you have written them down or fell you don’t need any codes just hold the throttle down until you see the ECM pattern change to ten fast flashes twice and then ten slow flashes and there you have one reset ECM


Right now i just dont see the MIL lighting up after pulling out my unit from the shop, perhaps Nissan Center didn't bother to go deeper diagnosis or the technician was a rookie.... My problem now is going to the diagnostic mode. I will try over and over to get into such mode. Ill feedback soonest. By the way, I forgot to mention my truck now aside from engine low power just accumulating a black smoke emission. Hope to hear from you guys.thanks and regards
 
1 - 10 of 10 Posts
Top