Nissan Frontier Forum banner

1 - 6 of 6 Posts

·
Registered
Joined
·
8 Posts
Discussion Starter #1
1998 Frontier Automatic.

I have a P0500 Speed sensor code check engine light. I replaced the speed sensor and it came back on. My Speedo doesn't work all the time. Sometimes it reads zero when driving sometimes it reads 80mph. So I'm thinking if I replace the instrument cluster I will hopefully remedy my problem.

A) Is there a good place to buy a quality used one?
B) How will it effect my odometer?

Normally I could care less if the speedo worked, but a check engine light for ANY reason prevents me from passing smog (California)

Thanks for any insight.
 

·
Premium Member
Joined
·
1,173 Posts
Mine is a second gen but I bought a like new one on eBay. There are a lot on there. I can't say how it will affect your odometer; I assume it's not controlled by the ECM or BCM or whatever you call it, so your new reading will be off unless there is a way to get it changed at a dealership.
 

·
Registered
Joined
·
36 Posts
Look into having it repaired. From what you describe it sounds like the motor that controls the position of the needle has gone bad. My fathers mid 2000's Chevy pickup does the exact same thing. Bad motors are quote common on GM vehicles. Repair is usually quite inexpensive and you maintain your OE cluster with the miles on it.
 

·
Registered
Joined
·
800 Posts
Agreed on having your cluster repaired. I sent mine away to be repaired to Mr. Whizard. My problem ended up being a no good aftermarket VSS but Mr. Whizard polished the cluster lens, replaced a bulb, and ran all the diagnostics without charging me anything other than the flat diagnostic fee.
 
1 - 6 of 6 Posts
Top