Nissan Frontier Forum banner
1 - 15 of 15 Posts

·
Registered
Joined
·
22 Posts
Discussion Starter · #1 ·
I am wondering if anyone here has/had problems with these. I have a 98 model with a tach 2wd 5 speed. The gas and temp gauges goes way past the H and F marks and the tach shakes and the speedo goes to about 15 mph and the milage is all 9's. I have googled it and it seems like a big problem with these clusters. Has anyone had this to happen and what did you do? I got another cluster but it could be messed up or will and the milage will be off from what i am told. I found a place online to fix it for i think almost $200.00. Nissan has no fix for these. Thanks
 

·
Registered
Joined
·
1,258 Posts
If you switch the cluster the mileage will show what is stored in that cluster, it will not change. I called Nissan to find out about getting my real mileage from the ECU maybe and changing what my replacement said. They said no and it is not stored in anything but the cluster.
 

·
Registered
Joined
·
60 Posts
pull one from a junk yard. Just right down what your old mileage was so you know what to tell the person who someday buys it. Or just say you don't drive it much if the new cluster has really low mileage. Check ebay also.
 

·
Registered
Joined
·
22 Posts
Discussion Starter · #4 ·
I already have one. I dont know what the milage of it is. The truck that i have is a 98 and has about 56000-58000 miles on it. I have talked to someone and said have it notarized with the right miles. I am thinking about putting it in myself, does not look hard but have to take all kinds of stuff off. I have a Chiltons book from the library and it shows the steering wheel off is this right? Anyone else here have this problem?
 

·
Registered
Joined
·
19 Posts
Mine is dying too

Anyone know how to pull/change the cluster? I want to check the connections first before replacing. Called nissan and they cannot help either. This sux.

My gauges all go to zero and I either read nothing on the odometer or just some random segments displayed. I am hoping It is just a loose harness connection. If not I don't know what to do.

Again, if anyone has directions to remove the cluster it would be greatly appreciated.
 

·
Registered
Joined
·
443 Posts
pulling the cluster is easy.. just take off your steering column covers, the lower dash cover, and the cluster trim ring. Then just take the three screws off the cluster, and undo the the connectors and that's it.
 

·
Registered
Joined
·
60 Posts
Anyone know if a 2001-2004 cluster will plug in to the 98-00 truck? What about the xterra? I found a few xterra's and a couple 02's. No 98's like mine. I wonder if it is plug and play?
 

·
Registered
Joined
·
13 Posts
:)
<br>
The only thing you can see now that its in, is my odometer went from 167k to 47k. They look Identical, this was from a 5/99 production, so perhaps my 98 is actually a very early 99? The membrane on the back was a -4, and the new one is a -5.
link
 
1 - 15 of 15 Posts
Top