Nissan Frontier Forum banner
1 - 7 of 7 Posts

·
Registered
Joined
·
5 Posts
Discussion Starter · #1 ·
Hey Everybody, looking for a little insight and guidance.

I have a 2006 Frontier, and I am having issues with the HVAC system.

The Blower Motor will not work on 1 or 2 but works fine on 3 and 4.

Conversely the A/C works fine on 1 and 2 (with no blower), but as soon as I switch to 3 or 4 the ac kicks off (literally, the led for the a/c shuts down as well as the recirculation led) and the blower kicks on.

Does this both on normal A/C and Max A/C.

So you can see my dilema.

I have checked all the fuses, they all seem to be in working order. Any suggestions on where to go next?

Any input is greatly appreciated.
 

·
Registered
Joined
·
60 Posts
HVAC Troubleshooting

Seems your HVAC control system is getting confused somewhere.
You checked the fuses, .... OK .... there are five fuses in the HVAC puzzle.
.
Suggest you download the free pdf Factory Service Manual (FSM) from the link in the DIY Sticky page of this site.
The FSM gives a complete wiring & step-by-step troubleshooting of the HVAC controls.
The FSM has those fancy Frontier pictures too.
.
 

·
Registered
Joined
·
271 Posts
Hey Everybody, looking for a little insight and guidance.

I have a 2006 Frontier, and I am having issues with the HVAC system.

The Blower Motor will not work on 1 or 2 but works fine on 3 and 4.

Conversely the A/C works fine on 1 and 2 (with no blower), but as soon as I switch to 3 or 4 the ac kicks off (literally, the led for the a/c shuts down as well as the recirculation led) and the blower kicks on.

Does this both on normal A/C and Max A/C.

So you can see my dilema.

I have checked all the fuses, they all seem to be in working order. Any suggestions on where to go next?

Any input is greatly appreciated.
If the fuses are ok, I'd be looking at the resistor. That's usually the issue if a couple speeds are missing in my experience.....
 

·
Registered
Joined
·
5 Posts
Discussion Starter · #4 ·
Got and Installed the Resistor over the weekend, had to order from a Nissan Dealer, $48 for the part is a little steep, BUT the good news it worked, problem solved, fan works on all speeds, and a/c works flawlessly.

Thanks for the Wisdom Guys (and Girls to be PC).
 

·
Registered
Joined
·
45 Posts
hey i have the same problem too, but problem is im not the best at electrical stuff, i know that all my fuses are fine but where is the resistor located?
 

·
Registered
Joined
·
5 Posts
Discussion Starter · #6 ·
Passenger Side, Under the Dash. Look @ the bottom or the black housing that holds all the blower hvac components. It it has a 4-lead plug going into it. disconnect the plug, and it will be held in place by two bolts/screws.
 
1 - 7 of 7 Posts
Top