Nissan Frontier Forum banner
1 - 2 of 2 Posts

·
Registered
Joined
·
832 Posts
Discussion Starter · #1 ·
My truck's doing dang awesome i must say, I'm starting to love it! Except for ABLS when I'm playing in the snow.

I have a major pissyfit over something though every morning.

I warm up my truck with the Heater fan speed set to 2 and the heat on hot.

I get in my truck after it warms up a bit and drive... after a few miles on the highway, it starts to get a wee bit hot in the cab, so... that's easy, turn the temperature dial to 1/2 cold/hot ... a few miles later I realize my hands are just about to melt the flesh off of them of scorching heat. I turn the dial to 100% cold. A few miles later, I resort to rolling the windows down and turning the heater to OFF completely because it won't stop blowing scorching HOT air into the already super-heated cab lol. ... A few-ish miles later I turn the blower back on, and hot air blasts... a few seconds later it blows ice cold air and responds to the temperature knob's position.


Observations: It will only do this if I turn the temperature to 100% hot, after that, only SOMETIMES does it respond when I change the temperature to a cooler setting. If it does not, it is VERY random when it does decide to come un-stuck from the 100% hot position.

When I'm sitting in the truck when the engine is off with the key on and the stereo muted, I can hear the servo's for the temperature flapper/valve moving with in correspondence with the knob's position. If I move it to HOT for more than a minute or so and then change it back to cold, I can't hear the servo even try to move... just gets stuck. If I leave it on 100% cold and just sit and wait, it may be 7 minutes or so till I hear the servo come alive and move the flapper/valve to the cold position.

Whatttts up with this?

thanks for the help
 

·
Registered
Joined
·
2,256 Posts
I had a similar problem. Mine would make a sound of creaking moving parts CONSTANTLY. If I set it to blow out the dash vents it would come out the floor, set it to the floor and it came out the dash. Or, it would cycle all over the place. However never with the temperature issue.
Now, I went to the dealership and they told me there was a known issue on the 05's where the HVAC had a problem finding the HOME positions for the diverter door. I was about a grand to fix and the whole dash had to come apart, blah blah blah. My warranty had just expired so I chose to ignore it. So to this day, it still makes some funny noises but I can live with it. For your problem with the heat, dang you may have to have the box replaced.
 
1 - 2 of 2 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top