Nissan Frontier Forum banner

1 - 11 of 11 Posts

·
Registered
Joined
·
13 Posts
Discussion Starter · #1 ·
Hello,
I've been hunting down a front end squeak on my 2005 Nismo. It's been there for years, always read it's the hood. Been reading through all the threads to mitigate and reading to adjust/lube the middle rubber hood stop. Well, I don't have a middle rubber stop, just the 2 outer ones over each of the headlamps that thread into the hood. I went to the dealership yesterday and the parts guy said it only has 2 as well. If there is supposed to be another rubber stop in the middle, can someone please provide me with a part number or picture?

Also, I've lubed the latch & loop. Re-tightened the latch. Backed out the rubber stops. I have pads duct-taped where the rubber stops rest near the headlamps to create a tighter tolerance. Lubed the hinges of the hood. Cannot reproduce the squeak, happens when going over quick bumps in the road (not speed bump in parking lot). Happens always on right turns with bumps in road. I've already replaced my sway bar bushings and end links, upper ball joints and steering tie-rods.

Thank you!

Pictures attached, not sure why they are upside-down.
 

Attachments

·
Registered
Joined
·
60 Posts
I looked today while checking trans fluid. I have one slightly off center and one on driver side? I think there is supposed by at least one more on passenger side that has been knocked off. Gonna check around online to get another 1 or 2..

-Kurt
2010 P4X
 

·
Registered
Joined
·
219 Posts
I have 3 on my 2007 LE.

Just a note, there is a TSB out for a squeaking noise that originates from these stops. I had the squeak and had to put a spacer under mine to stop it.
 

·
Registered
Joined
·
13 Posts
Discussion Starter · #5 ·
Thank you for the replies!

It seems i'm missing my center (off-center) bump stop - is this center bump stop different from the two outer bump stops? Looking at my hood, there isn't a matching hole in the middle where the outer rubber stop design would thread into.

Pics attached - please forgive the ugly foam duct tape job!
 

Attachments

·
Registered
2012 SV 4WD
Joined
·
87 Posts
I have 3 on my 2007 LE.

Just a note, there is a TSB out for a squeaking noise that originates from these stops. I had the squeak and had to put a spacer under mine to stop it.
Interesting... by any chance do you have a link for this TSB?
 

·
Registered
Joined
·
53 Posts
I have the same problem when it's cold and thought it was the hood but then noticed it coming from farther back at times . Come to find out it is the body mount bushings I loosened them up sprayed silicone and tighten them up haven't heard them since .
 

·
Registered
Joined
·
822 Posts
I've got three. 2013 model year. I had a squeak from my hood rests until I put a thin layer of grease on them. Been about 3 months now and no squeaks.
 

·
Registered
Joined
·
13 Posts
Discussion Starter · #10 ·
I just saw a 2014 that has 3 rubber stops, all alike. My 2005 only came with 2 as there isn’t a spot to thread in the 3rd.
 
1 - 11 of 11 Posts
Top