Nissan Frontier Forum banner

1 - 6 of 6 Posts

·
Registered
Joined
·
172 Posts
Discussion Starter #1
Was greasing my TC UCA's and noticed one of the three shock mount nuts is broken. Went around to the other side and one of three also broken (different location) on that side too??

I'm running one of the first PRG spacers.....d it looks like the design has changed since then. Bolts from top down instead of studs up with nuts.

I just can't figure out in my mind how this could have happend? and its bugging me. I don't do serious off-roading at all. Just a drive down un-paved roads once in a while...really strange.

Wonder if the stud on the spacer can be fixed or do I have too buy new spacers?
 

Attachments

·
Premium Member
Joined
·
9,798 Posts
Did you install the spacers?
 

·
Registered
Joined
·
3,545 Posts
Call Greg. Unless you are getting airborn I would not stress to an extreme amount, gravity will hold every thing in place.
 

·
Registered
Joined
·
172 Posts
Discussion Starter #6 (Edited)
Did you install the spacers?
Yeah I did them myself. I'm a total nerd. I always use a torque wrench even for a simple oil change.

Call Greg. Unless you are getting airborn I would not stress to an extreme amount, gravity will hold every thing in place.
Thanks. Not losing sleep over it...just really curious how it could have happened. I could see if my lower a-arm went out of alignment after the install but I got this "lifetime" alignment deal with a local shop and I take it in twice a year when I swap winter/summer wheels. Its never been out of spec.

I'm going to replace the front shocks soon I'll fix it then if possible.
Would love to try some Raflow's but can't justify the money based on the type of driving I do. Don't think they would be worth it for 99.5% highway driving.

I'm rambling because I've been drinking...sorry.
 
1 - 6 of 6 Posts
Top