Nissan Frontier Forum banner

1 - 10 of 10 Posts

·
Registered
Joined
·
13 Posts
Discussion Starter #1
98 2.4 . Little help please. The symptoms... High idle speed, totally falls on it face when slightly over revving the motor while changing gears, instrument cluster appears to be shorted out. It had a complete electrical tune up..plugs , wires, cap and button. Coil tested good. Mass air sensor changed and checked, good. Thps checked, good . Idle air cleaned. Cat. Converter checked for pressure before and after, good. Any ideas??
 

·
Registered
Joined
·
86 Posts
I woukd try a computer reset if you have not yet. Google on how to do a reset if it's like the newer ones it's a one minute procedure.
 

·
Registered
Joined
·
13 Posts
Discussion Starter #4
Fuel filter and oil change.....same symptoms. I really thinking ECM mostly because all the symptoms are opposite of what all the bad sensor symptoms are. Add the fact the dash cluster isn't working.
 

·
Registered
Joined
·
169 Posts
OBD2 readers are <$20. Or drive it to an autoparts store and they'll read the code(s) for you.
 

·
Registered
Joined
·
13 Posts
Discussion Starter #7
Changed idle air sensor and throttle position sensor,no change....ecm reset, no change. Im thinking bad ecm....ideas????
 

·
Registered
Joined
·
42 Posts
My 2004 is having a bit of issues too, except when the truck is sitting as it is on. It idles at 1k, a little below... But now KY even falls a little below that at times, kinda like a pulse. Never had this problem before.
 

·
Registered
2015 CC SL 4x4 - Lear Cap.
Joined
·
231 Posts
I was going to say, disconnect all the sensors you changed one at a time, won't run right but you will know when you hit the right one, the sensor might be the wrong parameters...pin (s) corroded, wire or plug cracked etc...you can chase it back. If any of them have gaskets make sure its the right one..
 
1 - 10 of 10 Posts
Top