Nissan Frontier Forum banner

1 - 8 of 8 Posts

·
Registered
Joined
·
4 Posts
Discussion Starter #1
I am from east texas and have owned my 2007 Frontier XE since day one! Just had a valve job done after having it jump time while replacing the Campostion Sensor and the Crank position sensor. Still wont start. I am here looking for help. I literally parked the truck after having some starting issues, replaced the sensors with NISSAN sensors and then it jumped time due to slack in the timing guides. Dealership wanted $5000+... replaced myself and now back to square one. No spark, but plenty of gas... Any help would be great! Thanks in advance!
 

·
Registered
Joined
·
14 Posts
Are you sure the timing is right?
 

·
Registered
Joined
·
4 Posts
Discussion Starter #4
Are you sure the timing is right?
I followed the Chilton book and made sure it was tdc. Once the head was on and timing chain synced I turned the motor manually and waited to hear compression out of the first piston and verified the markings were correct on the two cams and the crank. The motor turns over fine and sounds normal.
 

·
Premium Member
Joined
·
2,444 Posts
Hello from San Antonio, where are you from?
 

·
Registered
Joined
·
4 Posts
Discussion Starter #8
Hello from San Antonio, where are you from?
I am from the greater Tyler Area. Still having issues with my Frontier, but checking all connections and testing voltage on all relays, sensors and will test the PCM soon. Hopefully Ill have some answers soon!
 
1 - 8 of 8 Posts
Top