Nissan Frontier Forum banner
1 - 15 of 15 Posts

·
Registered
Joined
·
752 Posts
Discussion Starter · #1 ·
I had to make some advasive maneuvers yesterday to avoid rear ending someone. I locked up the brake a bit, but then let off of them and went into the shoulder of the road (30mph at the most) and it really wasn't all that bumpy. About a mile down the road my diff light came on, now I was in 2wd. I pulled over and turned the truck off and recranked the truck and it was off. I started driving home and it came on again and right after that happened the diff light turned off and the ABS light came on and the SLIP light. It didn't feel like anything was activated. ANY IDEAS?????? I was only about a mile away from home so I just drove home.
 

·
Registered
Joined
·
220 Posts
me too :(

just happened an hour ago. Yesterday I did 40 minutes at the pressure washer, spent alot of time underneath. Could I of gotten water into a connector?
 

·
Registered
Joined
·
752 Posts
Discussion Starter · #6 ·
My truck sat for three days till the weekend. I did a really looking and tugging thing underneath and didn't see anything. I cranked it up and it's been running fine every since. Go figure....
 

·
Registered
Joined
·
220 Posts
My truck sat for three days till the weekend. I did a really looking and tugging thing underneath and didn't see anything. I cranked it up and it's been running fine every since. Go figure....
mine was ok for 2 days afterwards. Then I went on a 200km drive to do some fishing. Once I was off-road it started flashing DIFF/VDC, whether I was in 2hi or 4hi. Seemed the bumpier it was, the more it would stay on. When I left and got on the highway it kept flashing, which I didnt think as cool at 100kph. I shut it off, and then back on. Then it was just the ABS/Slip light that stayed on for 200kms back home. If my locker actually was engaging everytime the light flashed well it got quite a workout, must be thousands of times. Since then (2 more days) it hasnt flashed once. I am going back to same fishing spot saturday morning...if the light comes back I think I can assume something must be loose back there, heard someone mention abs sensor in the hub. It's going in for service soon anyways, hopefully not on a flatbed.
 

·
Registered
Joined
·
428 Posts
Bad sensor. Same thing happened to me but Nissan replaced it and a computer component for free. The sensor has a design flaw but they know how to fix it, mine hasn't done it again since
 

·
Registered
Joined
·
2,587 Posts
Cool. Something to think about anyway. Do you know the part-number/name of the part?
each wheel has a differant sensor, since the cable lengths are differant. So you'll need to figure out which one went bad before you can get a part number. Also differant between C200 and M226.

You can do this with a multi meter or just take it to the dealer.
 

·
Registered
Joined
·
752 Posts
Discussion Starter · #11 ·
It's back!!!! It's been a couple of months, but diff light is going crazy again. I'm going to try the dealership. If they don't replace it, I might file a claim on the ole insurance. Haven't had to in a long time.
 

·
Registered
Joined
·
854 Posts
What do you mean?

It's back!!!! It's been a couple of months, but diff light is going crazy again. I'm going to try the dealership. If they don't replace it, I might file a claim on the ole insurance. Haven't had to in a long time.
It’s your responsibility to maintain safe distance and speed.:willy_nilly:
What do you plan on, insurance fraud? :wtf:
 

·
Registered
Joined
·
752 Posts
Discussion Starter · #14 ·
The Damage?????

Well guys I'm not sure if it's right or not, but here's what is going on, and please feel free to chime in.

01NIZ: Serv & Inspection
Diff light, ABS and SLIP Light on
Work performed by Joseph B. (466)
Unrealized 25154-7S200 :Switch-Rear Dif
Code P1839 Current for Differential Switch-
Ordered Part and will Call Customer When Part
Comes in.

The part I was told is the dash switch. $71+$90 labor I'm not real confident if that's what they ordered that is what is wrong. I could be wrong????

On the bright side, my heater wasn't working when at idle, which has sucked the last couple days with frost all over the windshield. They performed a cooling system bleed, which I had tried to do by putting the front end up on ramps and opening the res cap, they said they were able to get an air pocket out. The heater is working great now. Still a little concern about how it got there, especially with the latest extension of the radiator warranty.

Any help you guys can lend would be awesome. Thanks!
 

·
Registered
Joined
·
752 Posts
Discussion Starter · #15 ·
Update

Truck was fine again for several months, but diff light started blinking/flickering at me again. I unhooked the soloid and position sensor that are attached to the rear diff and all the lights went away. Of course I couldn't lock the rear diff though. I decided to order both of those parts and replace them myself. BAD IDEA. I have no idea what happened, but my rear diff is now engaged and won't disengage, so the $200 I spent on the two parts was wasted.....

My light isn't lit on my dash either. I now have a check engine light on. I'm so sick to my stomach today. I really need my truck for labor day weekend, plus my Dad is extremely sick fighting cancer and I've been towing an utility trailer to his house to cut his grass.

Anybody got a name of a good psychiatris in middle GA?
 
1 - 15 of 15 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top