Nissan Frontier Forum banner
1 - 5 of 5 Posts

·
Registered
Joined
·
9 Posts
Discussion Starter · #1 ·
Hi all,

I'm a new member with a 2010 frontier pro 4x, crew cab, with 280,xxx km's on it. I purchased it back in September. Installed a new radiator, fixed a leaky rear diff gasket, did the brakes, and got a hell of a deal on a very nice felted Leer canopy ($300) that I'm very much enjoying, for work and play.

I love the truck and plan on keeping it for as long as it goes.

Since a cold and damp winter has set in on Vancouver Island, I have noticed with cold starts, that a very annoying and worrying clicking / clacking noise occurs for about 5-7 mins then completely stops once it warms up.

I've read about many suspects. The timing chain / broken guards (hoping that's not it) pulleys and bearings off the chain or alternator, and recently read it could be the pistons waiting for a coating of oil.. apparently that is common in Nissan's?

I took it in and the mechanic said he didn't hear anything which seemed crazy. Even my neighbor asked about it without me saying anything.

Anyways, I'm hoping to get some feedback from you guys that have much more experience and knowledge than myself.

Here's a link to a recording to help.

The sound captured is pretty accurate to it in person.

Thanks in advance! 👍✌
 

·
Premium Member
Joined
·
7,337 Posts
OP, if you've not already done so, post this in General Discussion. You'll get far more traffic there, fwiw.
 
  • Like
Reactions: Jeremyunrau88

·
Registered
Joined
·
9 Posts
Discussion Starter · #5 ·
Welcome to the forum! Glad to have you join us. Tons of great info here and full of good people that are more than happy to share their knowledge. Hope you stick around and find this forum useful!
It's a great forum. Seems like no stone has been left unturned. Thanks
 
1 - 5 of 5 Posts
Top