Nissan Frontier Forum banner

1 - 12 of 12 Posts

·
Registered
Joined
·
3 Posts
Discussion Starter #1
Hello all...

So, I've recently started having some issues with my truck - it's a '98, I bought it from a friend of mine towards the end of last year, and he really tried to run the poor thing into the ground before I became a big enough sucker to buy it.

I'm trying to slowly start getting things fixed on it... but stuff seems to be going wrong at a faster pace!!

I look forward to being able to pick all of your brains!! :)

~foxsy
 

·
Registered
Joined
·
4,266 Posts
Welcome and enjoy.

Whats the question?
 

·
Registered
Joined
·
3 Posts
Discussion Starter #6
Thanks for the warm welcome! :)

Nissan Ty - yes, it is a 4 cylinder, and it is 4 x 4.

My question is - How simple is it to replace the 02 censor? I'm pretty sure that's what's going on with it - I have the "evaporative emissions codes" that have tripped my check engine light, and my gas mileage is HORRIBLE. Also - do you think it would be low transmission fluid causing my truck to slip when I put it in gear (manual transmission)?

Thank you all for your help!
 

·
Premium Member
Joined
·
9,798 Posts
Thanks for the warm welcome! :)

Nissan Ty - yes, it is a 4 cylinder, and it is 4 x 4.

My question is - How simple is it to replace the 02 censor? I'm pretty sure that's what's going on with it - I have the "evaporative emissions codes" that have tripped my check engine light, and my gas mileage is HORRIBLE. Also - do you think it would be low transmission fluid causing my truck to slip when I put it in gear (manual transmission)?

Thank you all for your help!
A O2 sensor can be easy to replace but that is not part of the evaporative emissions. What code are you getting?

If you transmission is slipping and you have a manual transmission then that is your clutch.
 

·
Registered
Joined
·
3,874 Posts
Welcome to the party! Looks to be time for a new clutch... May want to have the transmission fluid changed with it though(if its been a while..) Like Mike said, what code are you getting?
 

·
Registered
Joined
·
3 Posts
Discussion Starter #11
I got two codes... P0440 and P1446, I believe... I left the paperwork at home but I'm almost positive that's it.

Back in March, I had the exhaust manifold replaced - it was cracked completely in half. I have a feeling it had been that way for quite a while, and the shop that fixed it for me said that it could have very well damaged the 02 censor. I still can't get the stupid thing to pass emissions...

And, it doesn't slip all the time - it's really only done it twice, and the second time it happened, it slipped all the way through 3rd gear - finally started running normal when I got into 4th gear.

Thanks again, all... :)
 
1 - 12 of 12 Posts
Top