Nissan Frontier Forum banner

1 - 11 of 11 Posts

·
Registered
Joined
·
48 Posts
Discussion Starter #1
Has anybody used aftermarket lights in the factory location? I dont mind running the electrical for a new switch...but curious about modding the fog light plugs (i have an SE with no lights...just dumb plugs). I may attempt to cut the factory cover plugs and do my own...cause for 200 bux for factory...i can get pretty damn nice lights for the same price.
 

·
Super Moderator
Joined
·
12,702 Posts
Lots of people on here put lights into the factory location.
I have the Hella DE Micros:



By after market I'm assuming you mean not Nissan OEM ones, is this correct?
 

·
Registered
Joined
·
48 Posts
Discussion Starter #3
correct...NON oem. Also did you just by the new trim rings, or did you modify the ones you had? (thanks for the pic btw)
 

·
Super Moderator
Joined
·
12,702 Posts
Hey no problem, the pic is actually in my gallery.

I ordered the proper OEM trim rings.
As you can see there is a gap around the light.
The Hellas are obviously smaller in diameter than factory.
Been toying with cutting up the factory "plugs" that came for blanking out the holes, it's a low priority thing though so I haven't yet.

Also, I used the full Hella harness and never touched any factory wiring.
Here's a link to the switch I ended up going with: http://www.clubfrontier.org/forums/f9/where-can-i-find-nissan-rocker-switch-33425/#post520044
Click the link in that post for a picture of the actual switch.
 

·
Registered
Joined
·
398 Posts
Who has used non-oem lights that filled up the entire opening? I saw the thread on here once where they used a 4" or 5" light and no trim ring, but have not been able to find it again. Any one know what I'm talking about?
 

·
Super Moderator
Joined
·
12,702 Posts
Who has used non-oem lights that filled up the entire opening? I saw the thread on here once where they used a 4" or 5" light and no trim ring, but have not been able to find it again. Any one know what I'm talking about?
http://www.clubfrontier.org/forums/f10/aftermarket-fog-light-install-w-pics-652/

http://www.clubfrontier.org/forums/f23/oem-style-fog-light-kit-install-7903/

http://www.clubfrontier.org/forums/f10/problems-piaas-water-mud-10407/

There's a couple of threads to sink your teeth into, pics too.
 

·
Registered
Joined
·
198 Posts
I've seen some postings with guys running Piaa 510's in the stock location. fills up the space completely, but i could not get any info on mounting them and aiming them. It looked like it fit flushed into the stock location less trim, so i'm guessing that they both would aim slightly outward.
 

·
Registered
Joined
·
14 Posts
Added question from newbie??

Bought my truck used and came with aftermarket fog lights installed. Whoever did it has the power wire hooked to the F17 fuse location which says O2 sensor Ign. Is this the good spot to connect it? If not which location is best? And could this have anything to do with the P1148 code that showed up a few days ago?? The switch for the fog lights was burnt out so I put a new one in, when I hooked up the ground wire it sparked a bit and blew the fuse (O2 sensor) and since then the service engine light has been on. Any ideas?? Sorry for all the questions.
 

·
Premium Member
Joined
·
4,892 Posts
Bought my truck used and came with aftermarket fog lights installed. Whoever did it has the power wire hooked to the F17 fuse location which says O2 sensor Ign. Is this the good spot to connect it? If not which location is best? And could this have anything to do with the P1148 code that showed up a few days ago?? The switch for the fog lights was burnt out so I put a new one in, when I hooked up the ground wire it sparked a bit and blew the fuse (O2 sensor) and since then the service engine light has been on. Any ideas?? Sorry for all the questions.
I would never wire lights on the same circuit as the O2 sensors. Do the lights actually work if put on a good circuit? what brand are they? what kind of amperage do they pull? I tend not to ever trust a P.O's wiring. Too many hacks out there.
 

·
Registered
Joined
·
14 Posts
Wiring looks good, just concerned about power point. I don't see an ACC location so which should I use?? As far as amperage, have to get back to you on that.

Also not sure what brand. Look like the cheapies from walmart.
 

·
Registered
Joined
·
14 Posts
Ok, so I moved the power wire to the F21 location which is Rev Lamp Ign. Seem to work fine here. My question is... is it possible I damaged the O2 sensors when it sparked and blew the fuse, thus service engine light coming on?
 
1 - 11 of 11 Posts
Top