Nissan Frontier Forum banner
1 - 5 of 16 Posts

· Registered
Joined
·
243 Posts
Any updates on the problem? I got the p0500 code and gonna go out and test the vss.I'm wondering if I'll get an accurate read since it only happened twice
and is running fine now.

anyone ever test one? how accessible is the sensor?
 

· Registered
Joined
·
243 Posts
just an update on this seems to be rare occurrence.I pulled the vss sensor and tested it with a meter.Spun the gear and got good voltage.Also checked continuity and passed also.cleaned it up and reinstalled it.plugged in my reader
and cleared the faults.Took it for a spin and had no problems till I went to work the next day where it started to buck for several seconds than go away on it's own and would not return till the next day.I never got the check light and never lost my speedo or any other gauges.I went to a u-pull-it auto junkyard in hopes to find a truck close to mine with no luck.I figured since this problem
is so rare I could take a chance with a used one from a junkyard and get away with it.

My next step it to check the ecm connections and wiring from the sensor to
the speed cluster.I have some info. on what terminals to check if anyone ever needs them.I will update this post once I find the culprit.
 

· Registered
Joined
·
243 Posts
Just wanna give an update on the speed sensor problem.I bit the bullet and replaced the speed sensor and got the same results.I finally got the cel
p0500 to come up.I noticed the truck stutters mostly at 2k rpm and I have to put in neutral then rev it and put it back in drive and it will fix itself for a while.

I'm kinda stuck on this one and need some help if anyone has any info. on what else it can be.Does anyone know if it's true that these ecm's have an 8 year
warranty on them? I thought I read that somewhere but not sure.

I guess I'm gonna try to check the gauge cluster and see if I find anything.
I unplugged the ecm harness and checked all the connections and everything was fine.Does anyone know what a combination meter is and where it's located?
It seems that I need to check continuity between ecm terminal 29 and combination meter terminal 2 according to directions I found online.

Hope none of you have to go through this one.It's a pain to drive with it and it's getting a bit dangerous. Thanks for any help....
 

· Registered
Joined
·
243 Posts
hey thanks for the info. makes sense that the combination meter is the speedometer.Wish they would just tell me that...lol. Whats weird about the whole situation is that I never lost any gauges during the hesitations.That's when I checked the vss for voltage as I spun it.I probably needed to place it on a small electric motor so I can have a constant voltage to see if it ever had a intermittent signal.

I'm gonna check for corroded grounds today.Any specific places I should check
besides under the hood?
 
1 - 5 of 16 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top